Skip to content

← Actionable
Critical, CVSS 9.1amended

proxy-addr vulnerable to IP spoofing via IPv4-mapped IPv6 trust subnet

CVE-2026-90711GHSA-jqcg-44mw-7w3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (proxy-addr 2.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm proxy-addr

    Affected
    >= 1.1.0, < 2.0.8
    Fixed in
    2.0.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-90711: 0.26% estimated exploitation activity in the next 30 days; percentile 17.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact proxy-addr determines which network hops are trusted proxies so that X-Forwarded-For can be believed. When an application configures a trust subnet as an IPv4-mapped IPv6 address with a short prefix, such as ::ffff:10.0.0.0/8 (the correct spelling is ::ffff:10.0.0.0/104), the subnet compiles with all-zero leading bits and matches every IPv4 address instead of the block it names. The same happens for any IPv6 trust subnet with zero leading bits, such as ::/1. Every unauthenticated client is then trusted as a proxy at hop 0, so proxyaddr(req, trust), and therefore req.ip and req.ips in Express, returns whatever the client sends in X-Forwarded-For. This defeats IP-based access control, rate limiting, geolocation, and audit logging. The misconfiguration compiles without any error, and the same block written correctly behaves correctly, so the difference is not visible from the configuration. Patches Upgrade to proxy-addr 2.0.8. An IPv4 address now matches an IPv6 trust subnet only…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jqcg-44mw-7w3h

  2. Revision 2 · amended ·

    Amended from osv record GHSA-jqcg-44mw-7w3h

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jqcg-44mw-7w3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-90711

Advisory: proxy-addr vulnerable to IP spoofing via IPv4-mapped IPv6 trust subnet
IDs: CVE-2026-90711, GHSA-jqcg-44mw-7w3h
Record: https://patchnext.com/advisories/cve-2026-90711 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: proxy-addr 2.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm proxy-addr: affected >= 1.1.0, < 2.0.8; fixed in 2.0.8

## Suggested inspection (read-only)
- `npm ls proxy-addr --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on proxy-addr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jqcg-44mw-7w3h (GitHub-reviewed advisory GHSA-jqcg-44mw-7w3h lists affected ranges: npm proxy-addr >=1.1.0 <2.0.8)
- Verified: https://osv.dev/vulnerability/GHSA-jqcg-44mw-7w3h (OSV record GHSA-jqcg-44mw-7w3h lists affected ranges: npm proxy-addr >=1.1.0 <2.0.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…