Skip to content

← Actionable
Medium, CVSS 5.3amended

multer vulnerable to Denial of Service via orphaned disk writes on aborted uploads

CVE-2026-88932GHSA-3pph-fpjx-jg34

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (multer 2.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm multer

    Affected
    >= 2.2.0, < 2.4.0
    Fixed in
    2.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-88932: 0.53% estimated exploitation activity in the next 30 days; percentile 45.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Multer's diskStorage can leave complete, orphaned files on disk when a multipart upload is aborted in the brief window before the storage engine assigns the file path. This is an incomplete fix of CVE-2026-5038: the earlier cleanup removes only in-flight uploads that already have a path, so an upload aborted inside that window is written to disk with nothing left to remove it, and the application is not given a handle to clean it up. An unauthenticated attacker sending aborted requests to any route backed by disk storage can accumulate orphaned files until the upload directory or the shared system temporary directory is exhausted. An asynchronous destination or filename widens the window. Patches Users should upgrade to 2.4.0 or higher. Workarounds None.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3pph-fpjx-jg34

  2. Revision 2 · amended ·

    Amended from osv record GHSA-3pph-fpjx-jg34

  3. Revision 1 · created ·

    Published from ghsa record GHSA-3pph-fpjx-jg34

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-88932

Advisory: multer vulnerable to Denial of Service via orphaned disk writes on aborted uploads
IDs: CVE-2026-88932, GHSA-3pph-fpjx-jg34
Record: https://patchnext.com/advisories/cve-2026-88932 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: multer 2.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm multer: affected >= 2.2.0, < 2.4.0; fixed in 2.4.0

## Suggested inspection (read-only)
- `npm ls multer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on multer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3pph-fpjx-jg34 (GitHub-reviewed advisory GHSA-3pph-fpjx-jg34 lists affected ranges: npm multer >=2.2.0 <2.4.0)
- Verified: https://osv.dev/vulnerability/GHSA-3pph-fpjx-jg34 (OSV record GHSA-3pph-fpjx-jg34 lists affected ranges: npm multer >=2.2.0 <2.4.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…