amazon-redshift-python-driver vulnerable to Remote Code Execution via eval() Injection
CVE-2026-8838GHSA-29h4-r29x-hchv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (redshift-connector 2.1.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI redshift-connector
- Affected
- <= 2.1.13
- Fixed in
- 2.1.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-29h4-r29x-hchv lists affected ranges: PyPI redshift-connector >=0 <=2.1.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-29h4-r29x-hchv lists affected ranges: PyPI redshift-connector >=0 <2.1.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-8838: 0.81% estimated exploitation activity in the next 30 days; percentile 56.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary amazon-redshift-python-driver is the official Python connector for Amazon Redshift. In versions 2.1.13 and earlier, the driver insufficiently validates data received from the server during query result processing. A rogue server or man-in-the-middle could leverage this to execute arbitrary code on the client. Impact When a client connects to a rogue server implementing the PostgreSQL wire protocol, the server can send specially crafted query responses that the driver processes without adequate input validation. This could result in arbitrary code execution in the client process, potentially enabling command execution, file system access, or credential theft with the privileges of the client application. Impacted versions: <=2.1.13 Patches This has been addressed in amazon-redshift-python-driver version 2.1.14 (https://github.com/aws/amazon-redshift-python-driver/releases/tag/v2.1.14). Amazon Redshift recommends upgrading to the latest version and ensuring any forked or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-29h4-r29x-hchv
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-29h4-r29x-hchv
- Revision 1 · created ·
Published from ghsa record GHSA-29h4-r29x-hchv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-8838 Advisory: amazon-redshift-python-driver vulnerable to Remote Code Execution via eval() Injection IDs: CVE-2026-8838, GHSA-29h4-r29x-hchv Record: https://patchnext.com/advisories/cve-2026-8838 (revision 4, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: redshift-connector 2.1.14. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI redshift-connector: affected <= 2.1.13; fixed in 2.1.14 ## Suggested inspection (read-only) - `python -m pip show redshift-connector`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on redshift-connector. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-29h4-r29x-hchv (GitHub-reviewed advisory GHSA-29h4-r29x-hchv lists affected ranges: PyPI redshift-connector >=0 <=2.1.13) - Verified: https://osv.dev/vulnerability/GHSA-29h4-r29x-hchv (OSV record GHSA-29h4-r29x-hchv lists affected ranges: PyPI redshift-connector >=0 <2.1.14 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…