Skip to content

← Actionable
Medium, CVSS 5.5amended

ExifReader is vulnerable to denial of service via unbounded decompression of image metadata

CVE-2026-8814GHSA-rr89-w3h9-m66j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (exifreader 4.39.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm exifreader

    Affected
    >= 4.20.0, < 4.39.0
    Fixed in
    4.39.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-8814: 0.46% estimated exploitation activity in the next 30 days; percentile 40.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Versions of ExifReader from 4.20.0 through 4.38.1 do not bound the size of decompressed metadata blocks. When a caller invokes the asynchronous API (e.g. ExifReader.load(file) or ExifReader.load(buffer, {async: true})) on an attacker-supplied image, a small compressed chunk in the file can expand to hundreds of megabytes of memory, consuming heap and CPU until the process slows down or runs out of memory. The affected paths share a single decompression utility, so the issue is reachable through any compressed metadata block the library handles asynchronously, including: - PNG zTXt, compressed iTXt, and iCCP chunks (deflate) - JPEG XL Brotli-compressed Exif and XMP blocks A typical proof of concept produced roughly 1000× expansion (for example, ~32 KB of compressed input expanded to ~32 MB of output, ~130 KB to ~128 MB). Both the npm package and the dist/ bundle published from this repository (consumed by Bower and other users of the prebuilt artifact) are affected. Patches…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rr89-w3h9-m66j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rr89-w3h9-m66j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-8814

Advisory: ExifReader is vulnerable to denial of service via unbounded decompression of image metadata
IDs: CVE-2026-8814, GHSA-rr89-w3h9-m66j
Record: https://patchnext.com/advisories/cve-2026-8814 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: exifreader 4.39.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm exifreader: affected >= 4.20.0, < 4.39.0; fixed in 4.39.0

## Suggested inspection (read-only)
- `npm ls exifreader --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on exifreader.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rr89-w3h9-m66j (OSV record GHSA-rr89-w3h9-m66j lists affected ranges: npm exifreader >=4.20.0 <4.39.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rr89-w3h9-m66j (GitHub-reviewed advisory GHSA-rr89-w3h9-m66j lists affected ranges: npm exifreader >=4.20.0 <4.39.0)

Commands are suggestions: review each one before running it.

Loading voting…