Skip to content

← Actionable
High, CVSS 8.6amended

Angular SSR: XSS via Unescaped Processing Instruction ( ) Nodes in Fallback Raw-Content Elements

CVE-2026-88058GHSA-j3r3-mxqp-r2p4

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @angular/platform-server

    Affected
    >= 22.0.0, < 22.1.4>= 21.0.0, < 21.2.22>= 20.0.0, < 20.3.30<= 19.2.25
    Fixed in
    20.3.30, 22.1.4, 21.2.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-88058: 0.28% estimated exploitation activity in the next 30 days; percentile 20.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An XSS vulnerability exists in @angular/platform-server during server-side rendering (SSR) HTML serialization of ProcessingInstruction DOM nodes (<?target data?, nodeType === 7) when nested inside fallback raw-content elements (<noscript, <iframe, <noembed, <noframes). While processing instruction data escaped to &gt;, it did not check for or escape matching closing tags of ancestor fallback elements (e.g., </noscript). When rendered in a browser with scripting enabled, an unescaped closing tag sequence in a processing instruction prematurely closes the fallback raw-content tag and causes subsequent sibling elements to execute as live HTML. Technical Description In HTML5 parsing, fallback raw-content elements (<noscript, <iframe, <noembed, <noframes) place the browser's HTML tokenizer into RAWTEXT mode. In RAWTEXT mode, processing instruction tokens (<?...?) are treated as literal raw text rather than bogus comments, and the parser ignores or ?. The only token sequence that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-j3r3-mxqp-r2p4

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-j3r3-mxqp-r2p4

  4. Revision 1 · created ·

    Published from ghsa record GHSA-j3r3-mxqp-r2p4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-88058

Advisory: Angular SSR: XSS via Unescaped Processing Instruction ( ) Nodes in Fallback Raw-Content Elements
IDs: CVE-2026-88058, GHSA-j3r3-mxqp-r2p4
Record: https://patchnext.com/advisories/cve-2026-88058 (revision 4, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @angular/platform-server 22.1.4, 21.2.22, 20.3.30. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @angular/platform-server: affected >= 22.0.0, < 22.1.4; >= 21.0.0, < 21.2.22; >= 20.0.0, < 20.3.30; <= 19.2.25; fixed in 20.3.30, 22.1.4, 21.2.22

## Suggested inspection (read-only)
- `npm ls @angular/platform-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @angular/platform-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j3r3-mxqp-r2p4 (GitHub-reviewed advisory GHSA-j3r3-mxqp-r2p4 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25)
- Verified: https://osv.dev/vulnerability/GHSA-j3r3-mxqp-r2p4 (OSV record GHSA-j3r3-mxqp-r2p4 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25)

Commands are suggestions: review each one before running it.

Loading voting…