Angular: SSRF and Cross-Origin Credential Disclosure via URL Resolution Discrepancy in SSR
CVE-2026-88056GHSA-f6mr-pjwc-34m4
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 22.0.0, < 22.1.4>= 21.0.0, < 21.2.22>= 20.0.0, < 20.3.30<= 19.2.25
- Fixed in
- 20.3.30, 22.1.4, 21.2.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f6mr-pjwc-34m4 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f6mr-pjwc-34m4 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-88056: 0.54% estimated exploitation activity in the next 30 days; percentile 45.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A discrepancy between WHATWG URL parsing and Angular SSR's URL resolution allows attackers to bypass same-origin checks and cause Server-Side Request Forgery (SSRF), potentially leaking sensitive server-side credentials. Technical Description When applications validate incoming URLs using the WHATWG URL standard (new URL(input, trustedOrigin)), Unicode whitespace characters (such as NO-BREAK SPACE U+00A0 or ZERO WIDTH NO-BREAK SPACE U+FEFF) are not stripped and are evaluated as part of a same-origin relative path (e.g. http://trusted-origin/%C2%A0//attacker.example/collect). Consequently, these URLs successfully pass application-level same-origin checks. However, @angular/platform-server's URL resolution utility (resolveUrl / parseUrl) previously executed String.prototype.trim(). Because JavaScript's String.prototype.trim() strips all Unicode whitespace (including U+00A0), the leading non-breaking space was removed, converting the string into a cross-origin protocol-relative…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-f6mr-pjwc-34m4
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-f6mr-pjwc-34m4
- Revision 1 · created ·
Published from ghsa record GHSA-f6mr-pjwc-34m4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-88056 Advisory: Angular: SSRF and Cross-Origin Credential Disclosure via URL Resolution Discrepancy in SSR IDs: CVE-2026-88056, GHSA-f6mr-pjwc-34m4 Record: https://patchnext.com/advisories/cve-2026-88056 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/platform-server 22.1.4, 21.2.22, 20.3.30. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/platform-server: affected >= 22.0.0, < 22.1.4; >= 21.0.0, < 21.2.22; >= 20.0.0, < 20.3.30; <= 19.2.25; fixed in 20.3.30, 22.1.4, 21.2.22 ## Suggested inspection (read-only) - `npm ls @angular/platform-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/platform-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f6mr-pjwc-34m4 (GitHub-reviewed advisory GHSA-f6mr-pjwc-34m4 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25) - Verified: https://osv.dev/vulnerability/GHSA-f6mr-pjwc-34m4 (OSV record GHSA-f6mr-pjwc-34m4 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25) Commands are suggestions: review each one before running it.
Loading voting…