Skip to content

← Actionable
Medium, CVSS 6.1amended

MongoDB: GridFS data disclosure and deletion via query-operator injection in file IDs

CVE-2026-88023GHSA-8fxw-fmj8-xp7j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongodb/mongodb 2.4.2, 1.24.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mongodb/mongodb

    Affected
    >= 1.1.0, < 1.24.5>= 2.0.0, < 2.4.2
    Fixed in
    1.24.5, 2.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-88023: 0.33% estimated exploitation activity in the next 30 days; percentile 25.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Improper neutralization of special elements in data query logic in the GridFS component of the MongoDB PHP Library can cause a caller-supplied structured file identifier to be interpreted as a query condition rather than as a literal identifier. An authenticated user who can influence the identifier passed by an affected application may obtain stored file content beyond the intended target or cause all GridFS file chunks in the affected bucket to be removed, rendering stored file content unreadable. The affected rename operation may also rename a stored file other than the intended target.

Patches Fixed in 1.21.5 and 2.4.2.

Workarounds Validate GridFS IDs.

References https://jira.mongodb.org/browse/PHPLIB-1929

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record GHSA-8fxw-fmj8-xp7j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-88023

Advisory: MongoDB: GridFS data disclosure and deletion via query-operator injection in file IDs
IDs: CVE-2026-88023, GHSA-8fxw-fmj8-xp7j
Record: https://patchnext.com/advisories/cve-2026-88023 (revision 2, source checked 25 Oct 2026, 04:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mongodb/mongodb 2.4.2, 1.24.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mongodb/mongodb: affected >= 1.1.0, < 1.24.5; >= 2.0.0, < 2.4.2; fixed in 1.24.5, 2.4.2

## Suggested inspection (read-only)
- Packagist mongodb/mongodb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mongodb/mongodb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8fxw-fmj8-xp7j (OSV record GHSA-8fxw-fmj8-xp7j lists affected ranges: Packagist mongodb/mongodb >=1.1.0 =2.0.0 <2.4.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…