Skip to content

← Actionable
Medium, CVSS 6.5amended

Open WebUI: Users denied by the OAuth role policy can still sign in via token exchange

CVE-2026-88006GHSA-wvm9-9g5j-623f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI open-webui

    Affected
    >= 0.8.0, < 0.11.1
    Fixed in
    0.11.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-88006: 0.37% estimated exploitation activity in the next 30 days; percentile 31.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Open WebUI's OAuth token exchange endpoint issues a session for a provider access token without running the OAuth role management that the normal OAuth login callback runs. A user whose provider roles the login callback would refuse, or would demote, could still obtain a working session at their existing role through this endpoint. Preconditions - ENABLEOAUTHTOKENEXCHANGE=True. It is disabled by default, so a default deployment is not affected. - ENABLEOAUTHROLEMANAGEMENT=True together with OAUTHALLOWEDROLES or OAUTHADMINROLES. Role management is off by default, and deployments not using it are not affected. - A valid, unexpired access token on the configured provider. - An Open WebUI account already linked to that provider subject, or an account with a matching email when OAUTHMERGEACCOUNTSBYEMAIL is enabled. This endpoint never creates accounts, so a token for a subject with no existing account is rejected. Impact An admin who relies on OAuth role management expects a user…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wvm9-9g5j-623f

  2. Revision 2 · amended ·

    Amended from osv record GHSA-wvm9-9g5j-623f

  3. Revision 1 · created ·

    Published from ghsa record GHSA-wvm9-9g5j-623f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-88006

Advisory: Open WebUI: Users denied by the OAuth role policy can still sign in via token exchange
IDs: CVE-2026-88006, GHSA-wvm9-9g5j-623f
Record: https://patchnext.com/advisories/cve-2026-88006 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected >= 0.8.0, < 0.11.1; fixed in 0.11.1

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wvm9-9g5j-623f (GitHub-reviewed advisory GHSA-wvm9-9g5j-623f lists affected ranges: PyPI open-webui >=0.8.0 <0.11.1)
- Verified: https://osv.dev/vulnerability/GHSA-wvm9-9g5j-623f (OSV record GHSA-wvm9-9g5j-623f lists affected ranges: PyPI open-webui >=0.8.0 <0.11.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…