Skip to content

← Actionable
High, CVSS 7.7amended

Open WebUI: SSRF into internal services via DNS rebinding in the Playwright web loader

CVE-2026-87996GHSA-4v28-j6q3-5m4r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI open-webui

    Affected
    >= 0.9.6, < 0.11.1
    Fixed in
    0.11.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-87996: 0.35% estimated exploitation activity in the next 30 days; percentile 29.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary With the Playwright web loader enabled, Open WebUI checks the address behind a user-submitted URL before allowing the request, then handed the request to the browser to perform. The browser resolved the hostname a second time, on its own, and that answer was never checked. An attacker who controls the authoritative DNS for a hostname they submit can answer the first lookup with a public address and the second with an internal one, so the browser connects to an address the check exists to block. The connection-layer pinning that protects the other fetch paths could not apply here, because the request ran inside the browser rather than through our own HTTP clients. Preconditions - WEBLOADERENGINE=playwright. This is not the default, and deployments on the default web loader are unaffected. - A reachable Playwright browser, either local or via PLAYWRIGHTWSURL. - Any authenticated user who can submit a URL for ingestion or trigger a web search. No administrator role is required.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4v28-j6q3-5m4r

  2. Revision 2 · amended ·

    Amended from osv record GHSA-4v28-j6q3-5m4r

  3. Revision 1 · created ·

    Published from ghsa record GHSA-4v28-j6q3-5m4r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-87996

Advisory: Open WebUI: SSRF into internal services via DNS rebinding in the Playwright web loader
IDs: CVE-2026-87996, GHSA-4v28-j6q3-5m4r
Record: https://patchnext.com/advisories/cve-2026-87996 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected >= 0.9.6, < 0.11.1; fixed in 0.11.1

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4v28-j6q3-5m4r (GitHub-reviewed advisory GHSA-4v28-j6q3-5m4r lists affected ranges: PyPI open-webui >=0.9.6 <0.11.1)
- Verified: https://osv.dev/vulnerability/GHSA-4v28-j6q3-5m4r (OSV record GHSA-4v28-j6q3-5m4r lists affected ranges: PyPI open-webui >=0.9.6 <0.11.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…