Skip to content

← Actionable
Medium, CVSS 4.3amended

Open WebUI: Channel members can overwrite another member's message via the chat completions endpoint

CVE-2026-87994GHSA-fmqh-xp37-5hr8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI open-webui

    Affected
    >= 0.9.5, < 0.11.1
    Fixed in
    0.11.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-87994: 0.37% estimated exploitation activity in the next 30 days; percentile 31.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Any member of a channel who can post to it could also replace the text of a message written by a different member. The channel branch of the chat completions endpoint checked that the caller may write to the channel, and that the targeted message belongs to that channel, but never checked that the caller actually wrote the message being edited. The message kept its original author, so the replacement text was displayed and stored as though the victim had written it. The dedicated channel message edit route performed the authorship check correctly and refused the same edit, so the two paths disagreed about who may modify a message. Preconditions - Channels must be enabled. ENABLECHANNELS defaults to False, so a default deployment is not affected until an administrator turns channels on. - The attacker must be an approved user holding write access to the target channel, which is the ordinary state for any participant. No elevated role, group membership or additional permission…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fmqh-xp37-5hr8

  2. Revision 2 · amended ·

    Amended from osv record GHSA-fmqh-xp37-5hr8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-fmqh-xp37-5hr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-87994

Advisory: Open WebUI: Channel members can overwrite another member's message via the chat completions endpoint
IDs: CVE-2026-87994, GHSA-fmqh-xp37-5hr8
Record: https://patchnext.com/advisories/cve-2026-87994 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected >= 0.9.5, < 0.11.1; fixed in 0.11.1

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fmqh-xp37-5hr8 (GitHub-reviewed advisory GHSA-fmqh-xp37-5hr8 lists affected ranges: PyPI open-webui >=0.9.5 <0.11.1)
- Verified: https://osv.dev/vulnerability/GHSA-fmqh-xp37-5hr8 (OSV record GHSA-fmqh-xp37-5hr8 lists affected ranges: PyPI open-webui >=0.9.5 <0.11.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…