Skip to content

← Actionable
Medium, CVSS 5.3amended

morgan vulnerable to Log Injection via unescaped double quote in quoted log fields

CVE-2026-87859GHSA-9f6g-j8ch-79g4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (morgan 1.12.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm morgan

    Affected
    < 1.12.1
    Fixed in
    1.12.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-87859: 0.41% estimated exploitation activity in the next 30 days; percentile 35.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Morgan writes attacker-controlled request data to the access log. Its escaping (added in 1.11.0 and 1.12.0) neutralizes control characters, the Unicode line separators, and backslash, but not the double quote (0x22), which is the field delimiter of the Apache combined log format morgan emits. An attacker who controls a quoted field (:user-agent, :referrer, the request URL, or the Basic auth :remote-user) can inject a double quote to close the field early and forge additional fields in the log record. The combined, common, and default formats, and any custom format that quotes a token, are affected. This is an incomplete fix of CVE-2026-5078 and CVE-2026-15603. Patches Users should upgrade to version 1.12.1. Workarounds Update to version 1.12.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9f6g-j8ch-79g4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9f6g-j8ch-79g4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9f6g-j8ch-79g4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-87859

Advisory: morgan vulnerable to Log Injection via unescaped double quote in quoted log fields
IDs: CVE-2026-87859, GHSA-9f6g-j8ch-79g4
Record: https://patchnext.com/advisories/cve-2026-87859 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: morgan 1.12.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm morgan: affected < 1.12.1; fixed in 1.12.1

## Suggested inspection (read-only)
- `npm ls morgan --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on morgan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9f6g-j8ch-79g4 (GitHub-reviewed advisory GHSA-9f6g-j8ch-79g4 lists affected ranges: npm morgan >=0 <1.12.1)
- Verified: https://osv.dev/vulnerability/GHSA-9f6g-j8ch-79g4 (OSV record GHSA-9f6g-j8ch-79g4 lists affected ranges: npm morgan >=0 <1.12.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…