georgringer/news has SQL Injection in extension "News system" (news)
CVE-2026-8726GHSA-g868-j3qm-4j28
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (georgringer/news 14.0.3, 13.0.2, 12.3.2, 11.4.4, 10.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist georgringer/news
- Affected
- >= 12.0.0, < 12.3.2>= 13.0.0, < 13.0.2>= 14.0.0, < 14.0.3< 10.0.4>= 11.0.0, < 11.4.4
- Fixed in
- 10.0.4, 13.0.2, 14.0.3, 11.4.4, 12.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g868-j3qm-4j28 lists affected ranges: Packagist georgringer/news >=12.0.0 =13.0.0 =14.0.0 =0 =11.0.0 <11.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-8726: 0.44% estimated exploitation activity in the next 30 days; percentile 38.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The extension fails to properly sanitize user input before using it in a database query. As a result, an unauthenticated attacker can inject arbitrary SQL through a URL parameter on pages using the "Date Menu of news articles" plugin. Exploitation requires the "Date Menu of news articles" plugin to be in use and the TypoScript/Plugin setting disableOverrideDemand not to be enabled.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g868-j3qm-4j28
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-8726 Advisory: georgringer/news has SQL Injection in extension "News system" (news) IDs: CVE-2026-8726, GHSA-g868-j3qm-4j28 Record: https://patchnext.com/advisories/cve-2026-8726 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: georgringer/news 14.0.3, 13.0.2, 12.3.2, 11.4.4, 10.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist georgringer/news: affected >= 12.0.0, < 12.3.2; >= 13.0.0, < 13.0.2; >= 14.0.0, < 14.0.3; < 10.0.4; >= 11.0.0, < 11.4.4; fixed in 10.0.4, 13.0.2, 14.0.3, 11.4.4, 12.3.2 ## Suggested inspection (read-only) - Packagist georgringer/news: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on georgringer/news. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g868-j3qm-4j28 (GitHub-reviewed advisory GHSA-g868-j3qm-4j28 lists affected ranges: Packagist georgringer/news >=12.0.0 =13.0.0 =14.0.0 =0 =11.0.0 <11.4.4) Commands are suggestions: review each one before running it.
Loading voting…