qs has a remotely triggerable DoS: qs.stringify crashes with TypeError on null/undefined entries in comma-format arrays when encodeValuesOnly is set
CVE-2026-8723GHSA-q8mj-m7cp-5q26
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (qs 6.15.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm qs
- Affected
- >= 6.11.1, <= 6.15.1
- Fixed in
- 6.15.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q8mj-m7cp-5q26 lists affected ranges: npm qs >=6.11.1 <6.15.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q8mj-m7cp-5q26 lists affected ranges: npm qs >=6.11.1 <=6.15.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-8723: 0.40% estimated exploitation activity in the next 30 days; percentile 34.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary qs.stringify throws TypeError when called with arrayFormat: 'comma' and encodeValuesOnly: true on an array containing null or undefined. The throw is synchronous and not handled by any of qs's null-related options (skipNulls, strictNullHandling). Details In the comma + encodeValuesOnly branch, lib/stringify.js:145 mapped the array through the raw encoder before joining: utils.encode (lib/utils.js:195) reads str.length with no null guard, so a null or undefined element throws TypeError. skipNulls and strictNullHandling are both checked in the per-element loop below this line and never get a chance to run. Same class of bug as the filter-array path fixed in 0c180a4. The vulnerable shape of the comma + encodeValuesOnly branch was introduced in 4c4b23d ("encode comma values more consistently", PR #463, 2023-01-19), first released in v6.11.1. PoC Fix lib/stringify.js:145, applied in 21f80b3 on main: null and undefined now pass through maybeMap unchanged and reach the join(',')…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q8mj-m7cp-5q26
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q8mj-m7cp-5q26
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-8723 Advisory: qs has a remotely triggerable DoS: qs.stringify crashes with TypeError on null/undefined entries in comma-format arrays when encodeValuesOnly is set IDs: CVE-2026-8723, GHSA-q8mj-m7cp-5q26 Record: https://patchnext.com/advisories/cve-2026-8723 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: qs 6.15.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm qs: affected >= 6.11.1, <= 6.15.1; fixed in 6.15.2 ## Suggested inspection (read-only) - `npm ls qs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on qs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q8mj-m7cp-5q26 (OSV record GHSA-q8mj-m7cp-5q26 lists affected ranges: npm qs >=6.11.1 <6.15.2 (fixed)) - Verified: https://github.com/advisories/GHSA-q8mj-m7cp-5q26 (GitHub-reviewed advisory GHSA-q8mj-m7cp-5q26 lists affected ranges: npm qs >=6.11.1 <=6.15.1) Commands are suggestions: review each one before running it.
Loading voting…