Skip to content

← Actionable
Medium, CVSS 5.9amended

undici vulnerable to Denial of Service via unhandled exception in the decompress interceptor

CVE-2026-87029GHSA-55wc-3pg8-jfw6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.12.2, 7.30.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 7.15.0, < 7.30.1>= 8.0.0, < 8.12.2
    Fixed in
    8.12.2, 7.30.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-87029: 0.26% estimated exploitation activity in the next 30 days; percentile 17.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact undici's `decompress` interceptor forwards decompressed response data to the downstream handler from zlib stream event callbacks without catching exceptions those callbacks may throw. undici's engine converts a synchronous throw from a downstream handler into a per-request failure, but that protection is not in place when the throw happens asynchronously from a zlib callback. As a result, a downstream handler that throws by design, for example the built-in `dump` interceptor which throws when a response exceeds its `maxSize`, escapes as an uncaught exception and terminates the Node.js process. A malicious or compromised HTTP server can crash any client that composes the `decompress` interceptor with `dump` (or another response handler that throws), by returning a small compressed body that decompresses to more than the configured limit. The compressed bytes on the wire are tiny, so only the decompressed size matters. If the application keeps the process alive with a global…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-55wc-3pg8-jfw6

  2. Revision 1 · created ·

    Published from ghsa record GHSA-55wc-3pg8-jfw6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-87029

Advisory: undici vulnerable to Denial of Service via unhandled exception in the decompress interceptor
IDs: CVE-2026-87029, GHSA-55wc-3pg8-jfw6
Record: https://patchnext.com/advisories/cve-2026-87029 (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.12.2, 7.30.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 7.15.0, < 7.30.1; >= 8.0.0, < 8.12.2; fixed in 8.12.2, 7.30.1

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-55wc-3pg8-jfw6 (GitHub-reviewed advisory GHSA-55wc-3pg8-jfw6 lists affected ranges: npm undici >=7.15.0 =8.0.0 <8.12.2)
- Verified: https://osv.dev/vulnerability/GHSA-55wc-3pg8-jfw6 (OSV record GHSA-55wc-3pg8-jfw6 lists affected ranges: npm undici >=7.15.0 =8.0.0 <8.12.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…