Skip to content

← Actionable
High, CVSS 7.5amended

undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation

CVE-2026-87018GHSA-qrxm-fqhp-jwvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.12.2, 7.30.1, 6.29.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 4.2.1, < 6.29.1>= 7.0.0, < 7.30.1>= 8.0.0, < 8.12.2
    Fixed in
    8.12.2, 6.29.1, 7.30.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-87018: 0.19% estimated exploitation activity in the next 30 days; percentile 8.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact undici crashes the client process when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with `ERR_TLS_CERT_ALTNAME_INVALID`. undici's established socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught `AssertionError` that terminates the Node.js process. Both the HTTP/1.1 and HTTP/2 paths are affected. A malicious or compromised HTTPS endpoint reached through undici or the global `fetch()` can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process. Only TLS 1.2 is affected, because TLS 1.3 does not support renegotiation. Exploitation does not require a CA compromise: the attacker controls the endpoint and can present two ordinary…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-qrxm-fqhp-jwvm

  2. Revision 1 · created ·

    Published from ghsa record GHSA-qrxm-fqhp-jwvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-87018

Advisory: undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
IDs: CVE-2026-87018, GHSA-qrxm-fqhp-jwvm
Record: https://patchnext.com/advisories/cve-2026-87018 (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.12.2, 7.30.1, 6.29.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 4.2.1, < 6.29.1; >= 7.0.0, < 7.30.1; >= 8.0.0, < 8.12.2; fixed in 8.12.2, 6.29.1, 7.30.1

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qrxm-fqhp-jwvm (GitHub-reviewed advisory GHSA-qrxm-fqhp-jwvm lists affected ranges: npm undici >=4.2.1 =7.0.0 =8.0.0 <8.12.2)
- Verified: https://osv.dev/vulnerability/GHSA-qrxm-fqhp-jwvm (OSV record GHSA-qrxm-fqhp-jwvm lists affected ranges: npm undici >=4.2.1 =7.0.0 =8.0.0 <8.12.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…