Open WebUI: Sign-in as another user via wildcard characters in the OAuth subject claim on SQLite
CVE-2026-87016GHSA-wpmr-8h3q-fwj7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- >= 0.6.41, < 0.11.1
- Fixed in
- 0.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wpmr-8h3q-fwj7 lists affected ranges: PyPI open-webui >=0.6.41 <0.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wpmr-8h3q-fwj7 lists affected ranges: PyPI open-webui >=0.6.41 <0.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-87016: 0.60% estimated exploitation activity in the next 30 days; percentile 48.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary On SQLite deployments, the lookup that maps an external identity to a local account does a substring match instead of an exact match. A subject value containing SQL wildcard characters therefore matches accounts the value was never issued for, and the sign-in binds to whichever account the database returns first, which can be an administrator. The same defect affects SCIM external-ID resolution. PostgreSQL deployments are not affected, because they take a separate and correct code path. Preconditions The database is SQLite. This is the default backend. PostgreSQL deployments are not affected at all. OAuth or OIDC sign-in is configured, or SCIM provisioning is enabled. Both are off by default. For an attacker to steer the match deliberately, they must control the value of the claim Open WebUI uses as the subject. That value is normally assigned by the identity provider and is not attacker-controlled: the shipped GitHub and Feishu configurations use provider-assigned numeric…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wpmr-8h3q-fwj7
- Revision 2 · amended ·
Amended from osv record GHSA-wpmr-8h3q-fwj7
- Revision 1 · created ·
Published from ghsa record GHSA-wpmr-8h3q-fwj7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-87016 Advisory: Open WebUI: Sign-in as another user via wildcard characters in the OAuth subject claim on SQLite IDs: CVE-2026-87016, GHSA-wpmr-8h3q-fwj7 Record: https://patchnext.com/advisories/cve-2026-87016 (revision 3, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected >= 0.6.41, < 0.11.1; fixed in 0.11.1 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wpmr-8h3q-fwj7 (GitHub-reviewed advisory GHSA-wpmr-8h3q-fwj7 lists affected ranges: PyPI open-webui >=0.6.41 <0.11.1) - Verified: https://osv.dev/vulnerability/GHSA-wpmr-8h3q-fwj7 (OSV record GHSA-wpmr-8h3q-fwj7 lists affected ranges: PyPI open-webui >=0.6.41 <0.11.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…