Open WebUI: A user's session cookies are sent to tool servers configured for bearer authentication
CVE-2026-87015GHSA-p78m-89r6-pgf7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- >= 0.6.27, < 0.11.1
- Fixed in
- 0.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p78m-89r6-pgf7 lists affected ranges: PyPI open-webui >=0.6.27 <0.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p78m-89r6-pgf7 lists affected ranges: PyPI open-webui >=0.6.27 <0.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-87015: 0.48% estimated exploitation activity in the next 30 days; percentile 41.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When more than one external tool server is reachable in the same request, a tool call to a server configured for bearer authentication can arrive carrying the calling user's Open WebUI session cookies alongside that server's own key. The cookie jar is built per connection, but the callable that performs the request reads it late instead of per connection, so every tool callable built in the same pass sends the cookies belonging to whichever connection was processed last. An administrator who configures a server with its own API key has not chosen to send that server anything else, and the operator of that server receives a live session credential for the user who triggered the call. Preconditions At least two external tool servers must be attached to the same request, and at least one of them must be set to session or system OAuth authentication, since no cookie jar is assembled otherwise. The connection using that authentication mode must be the one processed last, which…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p78m-89r6-pgf7
- Revision 2 · amended ·
Amended from osv record GHSA-p78m-89r6-pgf7
- Revision 1 · created ·
Published from ghsa record GHSA-p78m-89r6-pgf7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-87015 Advisory: Open WebUI: A user's session cookies are sent to tool servers configured for bearer authentication IDs: CVE-2026-87015, GHSA-p78m-89r6-pgf7 Record: https://patchnext.com/advisories/cve-2026-87015 (revision 3, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected >= 0.6.27, < 0.11.1; fixed in 0.11.1 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p78m-89r6-pgf7 (GitHub-reviewed advisory GHSA-p78m-89r6-pgf7 lists affected ranges: PyPI open-webui >=0.6.27 <0.11.1) - Verified: https://osv.dev/vulnerability/GHSA-p78m-89r6-pgf7 (OSV record GHSA-p78m-89r6-pgf7 lists affected ranges: PyPI open-webui >=0.6.27 <0.11.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…