n8n: Git Node branch. .remote Config Key Bypasses Sandbox Path Restriction, Enabling Local Git Repository Read
CVE-2026-86995GHSA-qgpw-8g46-w95v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.38.2, 2.37.7, 1.123.76), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.76>= 2.38.0, < 2.38.2>= 2.0.0, < 2.37.7
- Fixed in
- 2.37.7, 1.123.76, 2.38.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qgpw-8g46-w95v lists affected ranges: npm n8n >=0 =2.38.0 =2.0.0 <2.37.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qgpw-8g46-w95v lists affected ranges: npm n8n >=0 =2.38.0 =2.0.0 <2.37.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2026-86995: 0.40% estimated exploitation activity in the next 30 days; percentile 34.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Git node validated the repository that a fetch or pull targeted, but setUpstream wrote a branch.<name.remote value into the repository's own configuration without validating it. A subsequent fetch or pull resolved the remote from that configuration rather than from the checked parameter, so an authenticated user with workflow-edit permission could point it at any local repository the n8n process could read and receive its contents. The patch validates the branch remote configuration on the same terms as the repository parameter. Patches The issue has been fixed in n8n versions 1.123.76, 2.37.7, and 2.38.2. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable the Git node by adding n8n-nodes-base.git to the NODESEXCLUDE environment variable. - Ensure…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-qgpw-8g46-w95v
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-qgpw-8g46-w95v
- Revision 1 · created ·
Published from ghsa record GHSA-qgpw-8g46-w95v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-86995 Advisory: n8n: Git Node branch. .remote Config Key Bypasses Sandbox Path Restriction, Enabling Local Git Repository Read IDs: CVE-2026-86995, GHSA-qgpw-8g46-w95v Record: https://patchnext.com/advisories/cve-2026-86995 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.38.2, 2.37.7, 1.123.76. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.76; >= 2.38.0, < 2.38.2; >= 2.0.0, < 2.37.7; fixed in 2.37.7, 1.123.76, 2.38.2 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qgpw-8g46-w95v (GitHub-reviewed advisory GHSA-qgpw-8g46-w95v lists affected ranges: npm n8n >=0 =2.38.0 =2.0.0 <2.37.7) - Verified: https://osv.dev/vulnerability/GHSA-qgpw-8g46-w95v (OSV record GHSA-qgpw-8g46-w95v lists affected ranges: npm n8n >=0 =2.38.0 =2.0.0 <2.37.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…