Skip to content

← Actionable
Medium, CVSS 4.8amended

fast-uri vulnerable to mailto header injection via percent-encoded field-name desynchronization

CVE-2026-86818GHSA-jvvf-x445-j334

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-uri

    Affected
    >= 4.1.3, < 4.1.5
    Fixed in
    4.1.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-86818: 0.25% estimated exploitation activity in the next 30 days; percentile 16.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact fast-uri's mailto scheme parser compares each query field name to the reserved names (to, subject, body) while the name is still percent-encoded, and only percent-decodes it when storing it as a generic header. On serialize, the decoded name is re-emitted, so a field name such as %74o (percent-encoded to) is not recognized as a recipient at parse time (parse().to shows only the legitimate recipient) but materializes as a literal to= field after serialize(), and reparsing then treats it as a recipient. The same technique smuggles subject and body through %73ubject and %62ody. An application that parses an untrusted mailto URI, makes a display, allowlist, or logging decision on parse().to, then re-serializes the result and passes the serialized string to a mail client or an outbound send path can gain an attacker-chosen recipient, subject, or body that was not visible when the recipient list was checked. A scanner inspecting the raw input for an extra to= sees nothing, because…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jvvf-x445-j334

  2. Revision 2 · amended ·

    Amended from osv record GHSA-jvvf-x445-j334

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jvvf-x445-j334

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-86818

Advisory: fast-uri vulnerable to mailto header injection via percent-encoded field-name desynchronization
IDs: CVE-2026-86818, GHSA-jvvf-x445-j334
Record: https://patchnext.com/advisories/cve-2026-86818 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-uri: affected >= 4.1.3, < 4.1.5; fixed in 4.1.5

## Suggested inspection (read-only)
- `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jvvf-x445-j334 (GitHub-reviewed advisory GHSA-jvvf-x445-j334 lists affected ranges: npm fast-uri >=4.1.3 <4.1.5)
- Verified: https://osv.dev/vulnerability/GHSA-jvvf-x445-j334 (OSV record GHSA-jvvf-x445-j334 lists affected ranges: npm fast-uri >=4.1.3 <4.1.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…