Skip to content

← Actionable
Medium, CVSS 6.5amended

Snowflake drivers writes sensitive information to logs

CVE-2026-86597GHSA-qqj6-54q6-cxv6

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/snowflakedb/gosnowflake

    Affected
    <= 1.19.1
    Fixed in
    no fixed version recorded
  • npm snowflake-sdk

    Affected
    < 3.3.0
    Fixed in
    3.3.0
  • Maven net.snowflake:snowflake-jdbc-fips

    Affected
    < 4.3.4
    Fixed in
    4.3.4
  • Maven net.snowflake:snowflake-jdbc-thin

    Affected
    < 4.3.4
    Fixed in
    4.3.4
  • PyPI snowflake-connector-python

    Affected
    < 4.7.3
    Fixed in
    4.7.3
  • Go github.com/snowflakedb/gosnowflake/v2

    Affected
    < 2.2.0
    Fixed in
    2.2.0
  • Maven net.snowflake:snowflake-jdbc

    Affected
    < 4.3.4
    Fixed in
    4.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-86597: 0.09% estimated exploitation activity in the next 30 days; percentile 0.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Insertion of sensitive information into log files in the Snowflake Python, Go, JDBC, Node.js, PHP PDO, and ODBC drivers allowed authentication tokens, query-result encryption keys, pre-signed cloud-storage URLs, and SAML assertions to be written to diagnostic logs in circumstances where the available log redaction did not cover all affected log paths and data types. An attacker with read access to the log destination, whether the local filesystem, a log aggregation service, or a CI/CD artifact store, could obtain credentials and decryption keys that, if still valid at the time of access, could be used to authenticate to the corresponding Snowflake account or cloud-storage object. Successful exploitation requires read access to the log destination, and impact is bounded by credential lifetime and object scope. The fix is available in Snowflake Connector for Python v4.7.3, Snowflake Go Driver v2.2.0, Snowflake JDBC Driver v4.3.4 (including the snowflake-jdbc-fips and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from ghsa record GHSA-qqj6-54q6-cxv6

  2. Revision 4 · amended ·

    Restored verified OSV alias package matches; original publication dates preserved

  3. Revision 3 · amended ·

    Amended from osv record GO-2026-6665

  4. Revision 2 · amended ·

    Amended from osv record GHSA-qqj6-54q6-cxv6

  5. Revision 1 · created ·

    Published from ghsa record GHSA-qqj6-54q6-cxv6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-86597

Advisory: Snowflake drivers writes sensitive information to logs
IDs: CVE-2026-86597, GHSA-qqj6-54q6-cxv6
Record: https://patchnext.com/advisories/cve-2026-86597 (revision 5, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: snowflake-sdk 3.3.0; net.snowflake:snowflake-jdbc-fips 4.3.4; net.snowflake:snowflake-jdbc-thin 4.3.4; snowflake-connector-python 4.7.3; github.com/snowflakedb/gosnowflake/v2 2.2.0; net.snowflake:snowflake-jdbc 4.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/snowflakedb/gosnowflake: affected <= 1.19.1
- npm snowflake-sdk: affected < 3.3.0; fixed in 3.3.0
- Maven net.snowflake:snowflake-jdbc-fips: affected < 4.3.4; fixed in 4.3.4
- Maven net.snowflake:snowflake-jdbc-thin: affected < 4.3.4; fixed in 4.3.4
- PyPI snowflake-connector-python: affected < 4.7.3; fixed in 4.7.3
- Go github.com/snowflakedb/gosnowflake/v2: affected < 2.2.0; fixed in 2.2.0
- Maven net.snowflake:snowflake-jdbc: affected < 4.3.4; fixed in 4.3.4

## Suggested inspection (read-only)
- Go github.com/snowflakedb/gosnowflake: check the installed version with your package manager.
- `npm ls snowflake-sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Maven net.snowflake:snowflake-jdbc-fips: check the installed version with your package manager.
- Maven net.snowflake:snowflake-jdbc-thin: check the installed version with your package manager.
- `python -m pip show snowflake-connector-python`: prints the installed version. Run with the environment that serves production active.
- Go github.com/snowflakedb/gosnowflake/v2: check the installed version with your package manager.
- Maven net.snowflake:snowflake-jdbc: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/snowflakedb/gosnowflake, snowflake-sdk, net.snowflake:snowflake-jdbc-fips, net.snowflake:snowflake-jdbc-thin, snowflake-connector-python, github.com/snowflakedb/gosnowflake/v2, net.snowflake:snowflake-jdbc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qqj6-54q6-cxv6 (GitHub-reviewed advisory GHSA-qqj6-54q6-cxv6 lists affected ranges: npm snowflake-sdk >=0 =0 <4.7.3)
- Verified: https://osv.dev/vulnerability/GO-2026-6665 (OSV record GO-2026-6665 lists affected ranges: Go github.com/snowflakedb/gosnowflake >=0; Go github.com/snowflakedb/gosnowflake/v2 >=0 <2.2.0 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-qqj6-54q6-cxv6 (OSV record GHSA-qqj6-54q6-cxv6 lists affected ranges: npm snowflake-sdk >=0 =0 =0 =0 =0 =0 =0 <2.2.0 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-qqj6-54q6-cxv6 (Verified OSV alias repair: npm:snowflake-sdk [{"fixed": "3.3.0", "introduced": "0"}])
- Verified: https://osv.dev/vulnerability/GHSA-qqj6-54q6-cxv6 (Verified OSV alias repair: PyPI:snowflake-connector-python [{"fixed": "4.7.3", "introduced": "0"}])
- Verified: https://osv.dev/vulnerability/GHSA-qqj6-54q6-cxv6 (Verified OSV alias repair: Maven:net.snowflake:snowflake-jdbc [{"fixed": "4.3.4", "introduced": "0"}])
- Verified: https://osv.dev/vulnerability/GHSA-qqj6-54q6-cxv6 (Verified OSV alias repair: Maven:net.snowflake:snowflake-jdbc-thin [{"fixed": "4.3.4", "introduced": "0"}])
- Verified: https://osv.dev/vulnerability/GHSA-qqj6-54q6-cxv6 (Verified OSV alias repair: Maven:net.snowflake:snowflake-jdbc-fips [{"fixed": "4.3.4", "introduced": "0"}])
- Verified: https://github.com/advisories/GHSA-qqj6-54q6-cxv6 (GitHub-reviewed advisory GHSA-qqj6-54q6-cxv6 lists affected ranges: npm snowflake-sdk >=0 =0 =0 =0 =0 =0 =0 <2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…