jsondiffpatch patch APIs are vulnerable to prototype pollution
CVE-2026-8657GHSA-j4fx-xxwh-2485
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsondiffpatch 0.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jsondiffpatch
- Affected
- < 0.7.6
- Fixed in
- 0.7.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j4fx-xxwh-2485 lists affected ranges: npm jsondiffpatch >=0 <0.7.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j4fx-xxwh-2485 lists affected ranges: npm jsondiffpatch >=0 <0.7.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-8657: 0.38% estimated exploitation activity in the next 30 days; percentile 31.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package jsondiffpatch before 0.7.6 are vulnerable to Prototype Pollution via the jsondiffpatch.patch() and jsondiffpatch/formatters/jsonpatch.patch() APIs. An attacker can perform prototype pollution by supplying crafted delta or JSON Patch documents, as attacker-controlled property names and path segments are used to traverse and modify objects without restricting access to special properties like proto or constructor.prototype, allowing modification of Object.prototype.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j4fx-xxwh-2485
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j4fx-xxwh-2485
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-8657 Advisory: jsondiffpatch patch APIs are vulnerable to prototype pollution IDs: CVE-2026-8657, GHSA-j4fx-xxwh-2485 Record: https://patchnext.com/advisories/cve-2026-8657 (revision 3, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jsondiffpatch 0.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jsondiffpatch: affected < 0.7.6; fixed in 0.7.6 ## Suggested inspection (read-only) - `npm ls jsondiffpatch --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jsondiffpatch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j4fx-xxwh-2485 (OSV record GHSA-j4fx-xxwh-2485 lists affected ranges: npm jsondiffpatch >=0 <0.7.6 (fixed)) - Verified: https://github.com/advisories/GHSA-j4fx-xxwh-2485 (GitHub-reviewed advisory GHSA-j4fx-xxwh-2485 lists affected ranges: npm jsondiffpatch >=0 <0.7.6) Commands are suggestions: review each one before running it.
Loading voting…