Skip to content

← Actionable
High, CVSS 7.8amended

knowns OS Command Injection via Insecure LSP Binary Path Config in .knowns/config.json

CVE-2026-86540GHSA-mc52-mwq4-vfx3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (knowns 0.30.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm knowns

    Affected
    <= 0.29.1
    Fixed in
    0.30.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-86540: 0.21% estimated exploitation activity in the next 30 days; percentile 11.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview A critical Arbitrary Code Execution (ACE) vulnerability exists in the Knowns Language Server Protocol (LSP) detection and startup pipeline. The system blindly trusts the settings.lsp.languages.<lang.binary field defined in the project-level .knowns/config.json file. Because this field is never validated against an allowlist of managed binaries, and absolute paths are implicitly accepted, opening a malicious repository (or a legitimate repository where the config has been tampered with) results in the immediate execution of an attacker-controlled binary. The payload is executed twice per session: once during the initial runVersionCheck (health check), and again when the LSP server process is spawned via Server.Start(). When chained with the previously identified Config Overwrite vulnerabilities, this flaw yields a fully unauthenticated Remote Code Execution chain. Affected paths | File Path | Role | Vulnerability & Execution Impact | | :--- | :--- | :--- | |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mc52-mwq4-vfx3

  2. Revision 2 · amended ·

    Amended from osv record GHSA-mc52-mwq4-vfx3

  3. Revision 1 · created ·

    Published from ghsa record GHSA-mc52-mwq4-vfx3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-86540

Advisory: knowns OS Command Injection via Insecure LSP Binary Path Config in .knowns/config.json
IDs: CVE-2026-86540, GHSA-mc52-mwq4-vfx3
Record: https://patchnext.com/advisories/cve-2026-86540 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: knowns 0.30.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm knowns: affected <= 0.29.1; fixed in 0.30.0

## Suggested inspection (read-only)
- `npm ls knowns --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on knowns.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mc52-mwq4-vfx3 (GitHub-reviewed advisory GHSA-mc52-mwq4-vfx3 lists affected ranges: npm knowns >=0 <=0.29.1)
- Verified: https://osv.dev/vulnerability/GHSA-mc52-mwq4-vfx3 (OSV record GHSA-mc52-mwq4-vfx3 lists affected ranges: npm knowns >=0 <0.30.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…