fast-uri vulnerable to inconsistent host case normalization via percent-encoded octets
CVE-2026-86472GHSA-hrr3-gc8f-f4qj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.1.5, 3.1.8, 2.4.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-uri
- Affected
- < 2.4.7>= 3.0.0, < 3.1.8>= 4.0.0, < 4.1.5
- Fixed in
- 4.1.5, 2.4.7, 3.1.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hrr3-gc8f-f4qj lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hrr3-gc8f-f4qj lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.1.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-86472: 0.25% estimated exploitation activity in the next 30 days; percentile 16.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact fast-uri folds the host to lowercase before it percent-decodes the host, so a percent-encoded uppercase unreserved octet such as %41 decodes to a literal A that is never folded. For a scheme-relative reference (//host) there is no scheme, so the host canonicalization that repairs this on a scheme-bearing URL does not run. As a result parse, normalize, and equal disagree on the same host: parse("//%41.com").host returns "A.com" while parse("//a.com").host and parse("//A.com").host return "a.com", and equal("//%41.com", "//a.com") is false even though equal("//A.com", "//a.com") is true. An application that makes a case-sensitive host decision on fast-uri output for a scheme-relative reference, for example a host allowlist or denylist that compares parse(url).host or uses fast-uri.equal, can be steered past the check with a percent-encoded uppercase octet. Because a hostname is case-insensitive in DNS and HTTP routing, the evading spelling reaches the same host the check meant…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hrr3-gc8f-f4qj
- Revision 2 · amended ·
Amended from osv record GHSA-hrr3-gc8f-f4qj
- Revision 1 · created ·
Published from ghsa record GHSA-hrr3-gc8f-f4qj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-86472 Advisory: fast-uri vulnerable to inconsistent host case normalization via percent-encoded octets IDs: CVE-2026-86472, GHSA-hrr3-gc8f-f4qj Record: https://patchnext.com/advisories/cve-2026-86472 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.1.5, 3.1.8, 2.4.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-uri: affected < 2.4.7; >= 3.0.0, < 3.1.8; >= 4.0.0, < 4.1.5; fixed in 4.1.5, 2.4.7, 3.1.8 ## Suggested inspection (read-only) - `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-uri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hrr3-gc8f-f4qj (GitHub-reviewed advisory GHSA-hrr3-gc8f-f4qj lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.1.5) - Verified: https://osv.dev/vulnerability/GHSA-hrr3-gc8f-f4qj (OSV record GHSA-hrr3-gc8f-f4qj lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.1.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…