Skip to content

← Actionable
Medium, CVSS 5.9amended

h3 has a Path Traversal via Percent-Encoded Dot Segments in serveStatic Allows Arbitrary File Read

CVE-2026-86253GHSA-wr4h-v87w-p3r7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (h3 2.0.1-rc.15, 1.15.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm h3

    Affected
    >= 2.0.0, <= 2.0.1-rc.14< 1.15.6
    Fixed in
    2.0.1-rc.15, 1.15.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-86253: 0.62% estimated exploitation activity in the next 30 days; percentile 49.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary serveStatic() in h3 is vulnerable to path traversal via percent-encoded dot segments (%2e%2e), allowing an unauthenticated attacker to read arbitrary files outside the intended static directory on Node.js deployments. Details The vulnerability exists in src/utils/static.ts at line 86: On Node.js, h3 uses srvx's FastURL class to parse request URLs. Unlike the standard WHATWG URL parser, FastURL extracts the pathname via raw string slicing for performance — it does not normalize dot segments (. / ..) or resolve percent-encoded equivalents (%2e). This means a request to /%2e%2e/ will have event.url.pathname return /%2e%2e/ verbatim, whereas the standard URL parser would normalize it to / (resolving .. upward). The serveStatic() function then calls decodeURI() on this raw pathname, which decodes %2e to ., producing /../. The resulting path containing ../ traversal sequences is passed directly to the user-provided getMeta() and getContents() callbacks with no sanitization or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wr4h-v87w-p3r7

  2. Revision 1 · created ·

    Published from osv record GHSA-wr4h-v87w-p3r7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-86253

Advisory: h3 has a Path Traversal via Percent-Encoded Dot Segments in serveStatic Allows Arbitrary File Read
IDs: CVE-2026-86253, GHSA-wr4h-v87w-p3r7
Record: https://patchnext.com/advisories/cve-2026-86253 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: h3 2.0.1-rc.15, 1.15.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm h3: affected >= 2.0.0, <= 2.0.1-rc.14; < 1.15.6; fixed in 2.0.1-rc.15, 1.15.6

## Suggested inspection (read-only)
- `npm ls h3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on h3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wr4h-v87w-p3r7 (OSV record GHSA-wr4h-v87w-p3r7 lists affected ranges: npm h3 >=2.0.0 =0 <1.15.6 (fixed))
- Verified: https://github.com/advisories/GHSA-wr4h-v87w-p3r7 (GitHub-reviewed advisory GHSA-wr4h-v87w-p3r7 lists affected ranges: npm h3 >=2.0.0 =0 <1.15.6)

Commands are suggestions: review each one before running it.

Loading voting…