n8n: Domain-Restriction Bypass via Unguarded Model-Search Endpoint in OpenAI Chat Model Node
CVE-2026-86082GHSA-34ff-336r-5q23
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.38.2, 2.37.7, 1.123.76), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.76>= 2.38.0, < 2.38.2>= 2.0.0, < 2.37.7
- Fixed in
- 2.37.7, 1.123.76, 2.38.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-34ff-336r-5q23 lists affected ranges: npm n8n >=0 =2.38.0 =2.0.0 <2.37.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-34ff-336r-5q23 lists affected ranges: npm n8n >=0 =2.38.0 =2.0.0 <2.37.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2026-86082: 0.41% estimated exploitation activity in the next 30 days; percentile 35.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The OpenAI Chat Model node checked a custom base URL against the credential's allowed-domains configuration before sending a request, but the model-search dropdown did not. A request setting options.baseURL on that path reached an arbitrary host with the credential attached, so the domain restriction an administrator configured did not hold for every route the node offered. The patch routes every OpenAI call site, including model listing, through one shared allowed-domains check. Patches The issue has been fixed in n8n versions 1.123.76, 2.37.7, and 2.38.2. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Audit all domain-restricted openAiApi credentials and revoke use-only shares granted to untrusted users. - Rotate any openAiApi credential secrets that may…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-34ff-336r-5q23
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-34ff-336r-5q23
- Revision 1 · created ·
Published from ghsa record GHSA-34ff-336r-5q23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-86082 Advisory: n8n: Domain-Restriction Bypass via Unguarded Model-Search Endpoint in OpenAI Chat Model Node IDs: CVE-2026-86082, GHSA-34ff-336r-5q23 Record: https://patchnext.com/advisories/cve-2026-86082 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.38.2, 2.37.7, 1.123.76. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.76; >= 2.38.0, < 2.38.2; >= 2.0.0, < 2.37.7; fixed in 2.37.7, 1.123.76, 2.38.2 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-34ff-336r-5q23 (GitHub-reviewed advisory GHSA-34ff-336r-5q23 lists affected ranges: npm n8n >=0 =2.38.0 =2.0.0 <2.37.7) - Verified: https://osv.dev/vulnerability/GHSA-34ff-336r-5q23 (OSV record GHSA-34ff-336r-5q23 lists affected ranges: npm n8n >=0 =2.38.0 =2.0.0 <2.37.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…