Skip to content

← Actionable
Medium, CVSS 5.9amended

n8n: Per-Resource OAuth Consent Bypass via Unbound Refresh Token Resource Substitution

CVE-2026-86073GHSA-cw9w-vv67-hf73

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.38.1, 2.37.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 2.38.0, < 2.38.1< 2.37.7
    Fixed in
    2.37.7, 2.38.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-86073: 0.39% estimated exploitation activity in the next 30 days; percentile 33.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The OAuth token endpoint bound an authorization code's first access token to the consented resource, but not its refresh token. Refreshing only checked that the requested resource was registered, not that it matched the original grant. An OAuth client approved for one workflow could refresh with a different workflow's URL and get a valid, unapproved token for it. The patch binds refresh tokens to the granted resource and rejects mismatches. Exploitation requires the attacker to register an OAuth client, convince an authenticated user to approve that client for one known protected resource, and know the URL of a second protected resource that the consenting user is permitted to execute. Patches The issue has been fixed in n8n versions 2.38.1 and 2.37.7. Users should upgrade to this version or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-cw9w-vv67-hf73

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-cw9w-vv67-hf73

  4. Revision 1 · created ·

    Published from ghsa record GHSA-cw9w-vv67-hf73

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-86073

Advisory: n8n: Per-Resource OAuth Consent Bypass via Unbound Refresh Token Resource Substitution
IDs: CVE-2026-86073, GHSA-cw9w-vv67-hf73
Record: https://patchnext.com/advisories/cve-2026-86073 (revision 4, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.38.1, 2.37.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 2.38.0, < 2.38.1; < 2.37.7; fixed in 2.37.7, 2.38.1

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cw9w-vv67-hf73 (GitHub-reviewed advisory GHSA-cw9w-vv67-hf73 lists affected ranges: npm n8n >=2.38.0 =0 <2.37.7)
- Verified: https://osv.dev/vulnerability/GHSA-cw9w-vv67-hf73 (OSV record GHSA-cw9w-vv67-hf73 lists affected ranges: npm n8n >=2.38.0 =0 <2.37.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…