lightrag-hku: Stored Cross-Site Scripting (XSS) in the LightRAG WebUI chat/answer renderer via ingested content
CVE-2026-86062GHSA-xpjq-3w4w-w5wr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightrag-hku 1.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lightrag-hku
- Affected
- <= 1.5.4
- Fixed in
- 1.5.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xpjq-3w4w-w5wr lists affected ranges: PyPI lightrag-hku >=0 <=1.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xpjq-3w4w-w5wr lists affected ranges: PyPI lightrag-hku >=0 <1.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-86062: 0.34% estimated exploitation activity in the next 30 days; percentile 27.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The LightRAG WebUI renders assistant/answer chat content as raw HTML — react-markdown is configured with rehypePlugins={[rehypeRaw]} and skipHtml={false} and no HTML sanitizer (rehype-sanitize), element allow-list, or custom urlTransform. Because answer content is derived from user-ingested documents, an attacker who can add a single document can store an HTML/JavaScript payload that executes in the browser of any user who later retrieves it (typically an administrator), leading to auth-token theft from localStorage and full API takeover. No authentication is required in the default configuration. Details Sink — lightragwebui/src/components/retrieval/ChatMessage.tsx: - Main answer (MessageMarkdown, lines ~348-351) and thinking content (lines ~252-272) render with rehypePlugins={[rehypeRaw, …]} and skipHtml={false}. The components map (lines ~111-156) only restyles safe formatting tags (p, h1–h4, ul, ol, li, code); there is no rehype-sanitize, no…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xpjq-3w4w-w5wr
- Revision 2 · amended ·
Amended from osv record GHSA-xpjq-3w4w-w5wr
- Revision 1 · created ·
Published from ghsa record GHSA-xpjq-3w4w-w5wr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-86062 Advisory: lightrag-hku: Stored Cross-Site Scripting (XSS) in the LightRAG WebUI chat/answer renderer via ingested content IDs: CVE-2026-86062, GHSA-xpjq-3w4w-w5wr Record: https://patchnext.com/advisories/cve-2026-86062 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lightrag-hku 1.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lightrag-hku: affected <= 1.5.4; fixed in 1.5.5 ## Suggested inspection (read-only) - `python -m pip show lightrag-hku`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lightrag-hku. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xpjq-3w4w-w5wr (GitHub-reviewed advisory GHSA-xpjq-3w4w-w5wr lists affected ranges: PyPI lightrag-hku >=0 <=1.5.4) - Verified: https://osv.dev/vulnerability/GHSA-xpjq-3w4w-w5wr (OSV record GHSA-xpjq-3w4w-w5wr lists affected ranges: PyPI lightrag-hku >=0 <1.5.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…