Jupyter Server: 5xx request logging leaks token-bearing Referer header values
CVE-2026-86049GHSA-c3mw-737p-c7g2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.21.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server
- Affected
- <= 2.20.0
- Fixed in
- 2.21.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c3mw-737p-c7g2 lists affected ranges: PyPI jupyter-server >=0 <=2.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c3mw-737p-c7g2 lists affected ranges: PyPI jupyter-server >=0 <2.21.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-86049: 0.42% estimated exploitation activity in the next 30 days; percentile 35.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When a request returns a 500, jupyterserver/log.py logs a small JSON block of request headers. The Referer header was copied into it as-is, so a token in the Referer URL ended up in the logs in plain text. Impact Anyone who can read the server logs can pick tokens out of these 500 entries. Tokens end up in the Referer during normal token-based login and launch flows. Affected: all versions before 2.21.0. PoC Any malformed request that returns a 500 works: The log shows the token twice, once raw and once redacted: Patches Fixed in 2.21.0 by 5251352. Header values are now scrubbed before the block is logged. Upgrade to 2.21.0 or later. Workarounds Limit who can read the server logs. If you can, avoid flows that put the token in the URL.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c3mw-737p-c7g2
- Revision 2 · amended ·
Amended from osv record GHSA-c3mw-737p-c7g2
- Revision 1 · created ·
Published from ghsa record GHSA-c3mw-737p-c7g2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-86049 Advisory: Jupyter Server: 5xx request logging leaks token-bearing Referer header values IDs: CVE-2026-86049, GHSA-c3mw-737p-c7g2 Record: https://patchnext.com/advisories/cve-2026-86049 (revision 3, source checked 26 Oct 2026, 13:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.21.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server: affected <= 2.20.0; fixed in 2.21.0 ## Suggested inspection (read-only) - `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c3mw-737p-c7g2 (GitHub-reviewed advisory GHSA-c3mw-737p-c7g2 lists affected ranges: PyPI jupyter-server >=0 <=2.20.0) - Verified: https://osv.dev/vulnerability/GHSA-c3mw-737p-c7g2 (OSV record GHSA-c3mw-737p-c7g2 lists affected ranges: PyPI jupyter-server >=0 <2.21.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…