libp2p: PeerStore accepts attacker-signed PeerRecords for a victim peer ID and stores certified attacker addresses
CVE-2026-86039GHSA-vrf4-mx87-p53w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@libp2p/peer-store 12.0.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 8.0.0, < 12.0.24
- Fixed in
- 12.0.24
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vrf4-mx87-p53w lists affected ranges: npm @libp2p/peer-store >=8.0.0 <12.0.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vrf4-mx87-p53w lists affected ranges: npm @libp2p/peer-store >=8.0.0 <12.0.24 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L
- EPSS
- CVE-2026-86039: 0.27% estimated exploitation activity in the next 30 days; percentile 19.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary @libp2p/peer-store accepts a signed PeerRecord whose envelope is signed by one peer but whose payload claims a different peer ID. The vulnerable consumePeerRecord path verifies the envelope signature, but does not verify that the envelope signer is the same peer as the wrapped PeerRecord.peerId. As a result, an attacker can sign a record with their own key while placing a victim peer ID in the payload, causing attacker-controlled multiaddrs to be stored as certified addresses for the victim. Details The vulnerable code is in packages/peer-store/src/index.ts: - RecordEnvelope.openAndCertify(buf, PeerRecord.DOMAIN, options) verifies the envelope signature. - const peerId = peerIdFromCID(envelope.publicKey.toCID()) derives the envelope signer peer ID. - The optional expectedPeer check only compares expectedPeer to the envelope signer. - const peerRecord = PeerRecord.createFromProtobuf(envelope.payload) decodes peerRecord.peerId from attacker-controlled signed payload bytes. -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vrf4-mx87-p53w
- Revision 2 · amended ·
Amended from osv record GHSA-vrf4-mx87-p53w
- Revision 1 · created ·
Published from ghsa record GHSA-vrf4-mx87-p53w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-86039 Advisory: libp2p: PeerStore accepts attacker-signed PeerRecords for a victim peer ID and stores certified attacker addresses IDs: CVE-2026-86039, GHSA-vrf4-mx87-p53w Record: https://patchnext.com/advisories/cve-2026-86039 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @libp2p/peer-store 12.0.24. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @libp2p/peer-store: affected >= 8.0.0, < 12.0.24; fixed in 12.0.24 ## Suggested inspection (read-only) - `npm ls @libp2p/peer-store --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @libp2p/peer-store. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vrf4-mx87-p53w (GitHub-reviewed advisory GHSA-vrf4-mx87-p53w lists affected ranges: npm @libp2p/peer-store >=8.0.0 <12.0.24) - Verified: https://osv.dev/vulnerability/GHSA-vrf4-mx87-p53w (OSV record GHSA-vrf4-mx87-p53w lists affected ranges: npm @libp2p/peer-store >=8.0.0 <12.0.24 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…