Skip to content

← Actionable
High, CVSS 7.5amended

libp2p: Gossipsub StrictSign accepts attacker-signed messages as a victim RSA peer ID

CVE-2026-86038GHSA-c3gv-825q-fvmp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@libp2p/gossipsub 16.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-86038: 0.19% estimated exploitation activity in the next 30 days; percentile 8.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @libp2p/gossipsub StrictSign validation does not bind a supplied message public key to the claimed from peer ID when from is an RSA-style peer ID that does not inline its public key. An attacker can set from to a victim RSA peer ID, sign the message with the attacker's own private key, include the attacker's public key in msg.key, and have the message accepted as a valid signed message from the victim. Details The vulnerable code is in packages/gossipsub/src/utils/buildRawMessage.ts inside validateToRawMessage. When msg.key is present: For RSA peer IDs parsed from the wire from multihash, fromPeerId.publicKey is undefined because the RSA public key is not inlined in the peer ID. This means the key-to-from comparison is skipped. The code then verifies the signature with the attacker-supplied msg.key and returns a signed message whose from is the victim RSA peer ID. The missing invariant is: This check must be performed whenever a public key is supplied, including keyless peer…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c3gv-825q-fvmp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-c3gv-825q-fvmp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-c3gv-825q-fvmp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-86038

Advisory: libp2p: Gossipsub StrictSign accepts attacker-signed messages as a victim RSA peer ID
IDs: CVE-2026-86038, GHSA-c3gv-825q-fvmp
Record: https://patchnext.com/advisories/cve-2026-86038 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @libp2p/gossipsub 16.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @libp2p/gossipsub: affected >= 15.0.0, < 16.0.5; fixed in 16.0.5

## Suggested inspection (read-only)
- `npm ls @libp2p/gossipsub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @libp2p/gossipsub.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c3gv-825q-fvmp (GitHub-reviewed advisory GHSA-c3gv-825q-fvmp lists affected ranges: npm @libp2p/gossipsub >=15.0.0 <16.0.5)
- Verified: https://osv.dev/vulnerability/GHSA-c3gv-825q-fvmp (OSV record GHSA-c3gv-825q-fvmp lists affected ranges: npm @libp2p/gossipsub >=15.0.0 <16.0.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…