Soup Sieve: Polynomial-time ReDoS (O(n²)) in the whitespace/comment trimming regex RE_WS_END (triggers on VALID selectors)
CVE-2026-85999GHSA-j934-xhv5-fg8f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (soupsieve 2.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI soupsieve
- Affected
- < 2.9.0
- Fixed in
- 2.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j934-xhv5-fg8f lists affected ranges: PyPI soupsieve >=0 <2.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j934-xhv5-fg8f lists affected ranges: PyPI soupsieve >=0 <2.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-85999: 0.61% estimated exploitation activity in the next 30 days; percentile 49.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Before tokenizing, selectoriter trims leading/trailing whitespace and comments by running two regexes over the whole raw selector with .search(). The trailing one, REWSEND = re.compile(r'{WSC}$'), is anchored only at the end ($), not the start. Because .search() retries the pattern at every offset, a long run of whitespace or CSS comments that is not sitting exactly at the end of the string makes each retry greedily consume the run and then fail $, producing O(n²) time. This triggers on perfectly valid selectors — e.g. a descendant combinator with a long whitespace gap, a + " "n + b — so no malformed input is required. A single valid ~20 KB selector stalls the interpreter for ~10 s of CPU. Trust model (Q0) The selector string is the input, reaching this code via soupsieve.compile(), the soupsieve.select/iselect/match/filter helpers, and BeautifulSoup's soup.select(selector) / soup.selectone(selector). Exploitable wherever an application passes a user-controlled CSS selector…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j934-xhv5-fg8f
- Revision 2 · amended ·
Amended from osv record GHSA-j934-xhv5-fg8f
- Revision 1 · created ·
Published from ghsa record GHSA-j934-xhv5-fg8f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-85999 Advisory: Soup Sieve: Polynomial-time ReDoS (O(n²)) in the whitespace/comment trimming regex `RE_WS_END` (triggers on VALID selectors) IDs: CVE-2026-85999, GHSA-j934-xhv5-fg8f Record: https://patchnext.com/advisories/cve-2026-85999 (revision 3, source checked 26 Oct 2026, 13:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: soupsieve 2.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI soupsieve: affected < 2.9.0; fixed in 2.9.0 ## Suggested inspection (read-only) - `python -m pip show soupsieve`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on soupsieve. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j934-xhv5-fg8f (GitHub-reviewed advisory GHSA-j934-xhv5-fg8f lists affected ranges: PyPI soupsieve >=0 <2.9.0) - Verified: https://osv.dev/vulnerability/GHSA-j934-xhv5-fg8f (OSV record GHSA-j934-xhv5-fg8f lists affected ranges: PyPI soupsieve >=0 <2.9.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…