Skip to content

← Actionable
Medium, CVSS 6.4amended

Amazon SageMaker Python SDK is missing integrity verification in its Triton inference handler

CVE-2026-8597GHSA-rq6v-x3j8-7qgf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sagemaker 3.8.0, 2.257.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI sagemaker

    Affected
    >= 2.199.0, <= 2.257.1>= 3.0.0, <= 3.7.1
    Fixed in
    2.257.2, 3.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-8597: 0.51% estimated exploitation activity in the next 30 days; percentile 43.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Amazon SageMaker Python SDK is an open-source library for training and deploying machine learning models on Amazon SageMaker. An issue exists where, under certain circumstances, the Triton inference handler deserializes model artifacts without performing integrity verification, allowing specially crafted pickle payloads to execute arbitrary code. Impact When using ModelBuilder with the Triton inference server, the Triton handler did not perform integrity verification before deserializing model artifacts. A remote authenticated actor with S3 write access to the model artifact path could replace model files with a crafted payload that would execute automatically on the next container lifecycle event, achieving code execution with the SageMaker execution role's IAM permissions. Impacted versions: = v2.199.0 AND <= v2.257.1, = v3.0.0 AND <= v3.7.1 Patches This issue has been addressed in Amazon SageMaker Python SDK v2.257.2 and v3.8.0. The Triton inference handler now performs…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rq6v-x3j8-7qgf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rq6v-x3j8-7qgf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-8597

Advisory: Amazon SageMaker Python SDK is missing integrity verification in its Triton inference handler
IDs: CVE-2026-8597, GHSA-rq6v-x3j8-7qgf
Record: https://patchnext.com/advisories/cve-2026-8597 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sagemaker 3.8.0, 2.257.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sagemaker: affected >= 2.199.0, <= 2.257.1; >= 3.0.0, <= 3.7.1; fixed in 2.257.2, 3.8.0

## Suggested inspection (read-only)
- `python -m pip show sagemaker`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sagemaker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rq6v-x3j8-7qgf (OSV record GHSA-rq6v-x3j8-7qgf lists affected ranges: PyPI sagemaker >=2.199.0 =3.0.0 <3.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rq6v-x3j8-7qgf (GitHub-reviewed advisory GHSA-rq6v-x3j8-7qgf lists affected ranges: PyPI sagemaker >=2.199.0 =3.0.0 <=3.7.1)

Commands are suggestions: review each one before running it.

Loading voting…