Skip to content

← Actionable
High, CVSS 7.1amended

lightrag-hku: SSRF via IPv6-transition address bypass (NAT64, IPv4-compatible, 6to4) of the native-markdown image-download guard

CVE-2026-85740GHSA-vv3m-f8x4-7377

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightrag-hku 1.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-85740: 0.26% estimated exploitation activity in the next 30 days; percentile 18.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary LightRAG's native markdown parser downloads external images referenced by an uploaded markdown or textpack document. The only SSRF guard, validatedaddresses() in lightrag/parser/markdown/parser.py, resolves the image host and rejects it when the resolved IP is not isglobal. That check is evaluated on the raw resolved address and never decodes IPv6 transition wrappers that embed an internal IPv4. Python's ipaddress classifies a NAT64 (64:ff9b::/96 and the RFC 8215 64:ff9b:1::/48 prefix), IPv4-compatible (::a.b.c.d), or 6to4 (2002::/16) literal that wraps an internal IPv4 as globally routable, so the guard passes it. On a host with NAT64/DNS64 routing the request is then delivered to the embedded internal target (loopback, RFC1918, or a cloud metadata endpoint), and the fetched body is ingested. The plain and IPv4-mapped (::ffff:) forms of the same internal address are correctly blocked, so this is an encoding that defeats the existing filter. Affected component and versions -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vv3m-f8x4-7377

  2. Revision 2 · amended ·

    Amended from osv record GHSA-vv3m-f8x4-7377

  3. Revision 1 · created ·

    Published from ghsa record GHSA-vv3m-f8x4-7377

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-85740

Advisory: lightrag-hku: SSRF via IPv6-transition address bypass (NAT64, IPv4-compatible, 6to4) of the native-markdown image-download guard
IDs: CVE-2026-85740, GHSA-vv3m-f8x4-7377
Record: https://patchnext.com/advisories/cve-2026-85740 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lightrag-hku 1.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lightrag-hku: affected < 1.5.5; fixed in 1.5.5

## Suggested inspection (read-only)
- `python -m pip show lightrag-hku`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lightrag-hku.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vv3m-f8x4-7377 (GitHub-reviewed advisory GHSA-vv3m-f8x4-7377 lists affected ranges: PyPI lightrag-hku >=0 <1.5.5)
- Verified: https://osv.dev/vulnerability/GHSA-vv3m-f8x4-7377 (OSV record GHSA-vv3m-f8x4-7377 lists affected ranges: PyPI lightrag-hku >=0 <1.5.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…