lightrag-hku: No Rate Limiting on /login Endpoint Allows Brute-Force Attacks
CVE-2026-85734GHSA-frch-4w6v-q5xx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightrag-hku 1.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lightrag-hku
- Affected
- < 1.5.5
- Fixed in
- 1.5.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-frch-4w6v-q5xx lists affected ranges: PyPI lightrag-hku >=0 <1.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-frch-4w6v-q5xx lists affected ranges: PyPI lightrag-hku >=0 <1.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-85734: 0.61% estimated exploitation activity in the next 30 days; percentile 49.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The POST /login endpoint has no rate limiting, account lockout, or delay on failed attempts. An attacker can submit unlimited password guesses at full network speed. Details A search for slowapi, ratelimit, lockout, or throttle in lightrag/api/ returns zero results. PoC Impact Improper restriction of authentication attempts. Any network-reachable attacker can brute-force user passwords without restriction. Once credentials are recovered, the attacker gains full authenticated access to all documents, knowledge graph, and administrative operations.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-frch-4w6v-q5xx
- Revision 2 · amended ·
Amended from osv record GHSA-frch-4w6v-q5xx
- Revision 1 · created ·
Published from ghsa record GHSA-frch-4w6v-q5xx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-85734 Advisory: lightrag-hku: No Rate Limiting on /login Endpoint Allows Brute-Force Attacks IDs: CVE-2026-85734, GHSA-frch-4w6v-q5xx Record: https://patchnext.com/advisories/cve-2026-85734 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lightrag-hku 1.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lightrag-hku: affected < 1.5.5; fixed in 1.5.5 ## Suggested inspection (read-only) - `python -m pip show lightrag-hku`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lightrag-hku. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-frch-4w6v-q5xx (GitHub-reviewed advisory GHSA-frch-4w6v-q5xx lists affected ranges: PyPI lightrag-hku >=0 <1.5.5) - Verified: https://osv.dev/vulnerability/GHSA-frch-4w6v-q5xx (OSV record GHSA-frch-4w6v-q5xx lists affected ranges: PyPI lightrag-hku >=0 <1.5.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…