rubyzip path traversal vulnerability
CVE-2026-85396GHSA-47m2-wp7j-p9vc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rubyzip 3.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rubyzip
- Affected
- < 3.4.0
- Fixed in
- 3.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-47m2-wp7j-p9vc lists affected ranges: RubyGems rubyzip >=0 <3.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-47m2-wp7j-p9vc lists affected ranges: RubyGems rubyzip >=0 <3.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-85396: 0.56% estimated exploitation activity in the next 30 days; percentile 46.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
rubyzip versions before 3.4.0 contain a path traversal vulnerability in Zip::Entry#extract that fails to properly validate extraction paths using prefix comparison without trailing separators. Attackers can craft archive entries with names like ../uploadbackup/owned.sh to write files outside the intended extraction directory into sibling paths sharing the destination prefix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-47m2-wp7j-p9vc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-47m2-wp7j-p9vc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-85396 Advisory: rubyzip path traversal vulnerability IDs: CVE-2026-85396, GHSA-47m2-wp7j-p9vc Record: https://patchnext.com/advisories/cve-2026-85396 (revision 3, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rubyzip 3.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rubyzip: affected < 3.4.0; fixed in 3.4.0 ## Suggested inspection (read-only) - RubyGems rubyzip: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rubyzip. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-47m2-wp7j-p9vc (OSV record GHSA-47m2-wp7j-p9vc lists affected ranges: RubyGems rubyzip >=0 <3.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-47m2-wp7j-p9vc (GitHub-reviewed advisory GHSA-47m2-wp7j-p9vc lists affected ranges: RubyGems rubyzip >=0 <3.4.0) Commands are suggestions: review each one before running it.
Loading voting…