undici vulnerable to cross-origin cache poisoning via missing origin isolation in interceptors
CVE-2026-85152GHSA-vp8m-p9jh-q5pm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 8.10.0, < 8.10.2
- Fixed in
- 8.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vp8m-p9jh-q5pm lists affected ranges: npm undici >=8.10.0 <8.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vp8m-p9jh-q5pm lists affected ranges: npm undici >=8.10.0 <8.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-85152: 0.16% estimated exploitation activity in the next 30 days; percentile 5.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When interceptors.cache() or interceptors.deduplicate() is used with a dispatcher that does not carry a single authoritative origin, or when a request supplies its own origin, undici builds the cache and deduplication keys without the actual destination origin. If a cache store or interceptor instance is shared across more than one origin, otherwise-identical requests to different origins are keyed together. An attacker who controls the response from one origin can then have that response returned for a request to a different, trusted origin when the method, path, and relevant headers match. This allows cross-origin information disclosure and persistent cache poisoning, including chains such as JWKS cache poisoning where a token signed with an attacker-held key is accepted as belonging to a trusted issuer. Applications that share interceptors.cache() or interceptors.deduplicate() state across origins are affected. An Agent is not affected, because its dispatch options include…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vp8m-p9jh-q5pm
- Revision 2 · amended ·
Amended from osv record GHSA-vp8m-p9jh-q5pm
- Revision 1 · created ·
Published from ghsa record GHSA-vp8m-p9jh-q5pm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-85152 Advisory: undici vulnerable to cross-origin cache poisoning via missing origin isolation in interceptors IDs: CVE-2026-85152, GHSA-vp8m-p9jh-q5pm Record: https://patchnext.com/advisories/cve-2026-85152 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 8.10.0, < 8.10.2; fixed in 8.10.2 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vp8m-p9jh-q5pm (GitHub-reviewed advisory GHSA-vp8m-p9jh-q5pm lists affected ranges: npm undici >=8.10.0 <8.10.2) - Verified: https://osv.dev/vulnerability/GHSA-vp8m-p9jh-q5pm (OSV record GHSA-vp8m-p9jh-q5pm lists affected ranges: npm undici >=8.10.0 <8.10.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…