Skip to content

← Actionable
Medium, CVSS 6.9amended

Colord: Slow rejection of oversized malformed color strings

CVE-2026-85062GHSA-2wm5-q62r-hmrv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (colord 2.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm colord

    Affected
    < 2.9.4
    Fixed in
    2.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-85062: 0.51% estimated exploitation activity in the next 30 days; percentile 43.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact colord's CSS color string matchers described a number as ([+-]?\d\.?\d+). In that form \d and \d+ can match the same digits, so a run of n digits can be divided between them in O(n²) ways, and rejecting an input retries every division. Parsing is synchronous and uninterruptible, so a long malformed color string blocks the thread: | input | time to reject | | --- | --- | | 16 KB | 224 ms | | 64 KB | 4.4 s | | 128 KB | 18.5 s | Reachable through colord() and getFormat(), and through any method that accepts a color string — including isEqual(), mix() and contrast(). The affected matchers are parseRgbaString and parseHslaString (built in) and parseHwbaString, parseLchaString, parseCmykaString (plugins). Growth is polynomial, not exponential — multi-kilobyte payloads are required for a noticeable stall. Who is affected Applications that pass attacker-controlled strings of unbounded length to colord() — for example a server validating a color taken from a request body, JSON field,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-2wm5-q62r-hmrv

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-2wm5-q62r-hmrv

  4. Revision 1 · created ·

    Published from ghsa record GHSA-2wm5-q62r-hmrv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-85062

Advisory: Colord: Slow rejection of oversized malformed color strings
IDs: CVE-2026-85062, GHSA-2wm5-q62r-hmrv
Record: https://patchnext.com/advisories/cve-2026-85062 (revision 4, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: colord 2.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm colord: affected < 2.9.4; fixed in 2.9.4

## Suggested inspection (read-only)
- `npm ls colord --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on colord.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2wm5-q62r-hmrv (GitHub-reviewed advisory GHSA-2wm5-q62r-hmrv lists affected ranges: npm colord >=0 <2.9.4)
- Verified: https://osv.dev/vulnerability/GHSA-2wm5-q62r-hmrv (OSV record GHSA-2wm5-q62r-hmrv lists affected ranges: npm colord >=0 <2.9.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…