Skip to content

← Actionable
Critical, CVSS 9.8amended

Langflow: Unauthenticated Flow Execution via Webhook Authentication Bypass

CVE-2026-8505GHSA-cf6m-vc3m-7cgm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langflow

    Affected
    >= 1.7.0, <= 1.9.0
    Fixed in
    1.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-8505: 0.87% estimated exploitation activity in the next 30 days; percentile 58.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability in Langflow's webhook authentication logic allows unauthenticated users to trigger the execution of any flow. The system incorrectly bypasses API key validation when the WEBHOOKAUTHENABLE configuration is set to False. This allows a remote attacker who knows a flow's UUID to execute it as if they were the owner, potentially leading to Remote Code Execution (RCE) or Denial of Service (DoS). Details The WEBHOOKAUTHENABLE setting was introduced in v1.7.0 (#9139) with a default of False. The root cause is in the webhook authentication path, AuthService.getwebhookuser (src/backend/base/langflow/services/auth/service.py; the thin wrapper in src/backend/base/langflow/services/auth/utils.py just delegates to it): By default (v1.7.0 through v1.9.0), Langflow treats WEBHOOKAUTHENABLE as False, meaning all webhook endpoints are public. This relies exclusively on the secrecy of the flowid (UUID), which is an insecure practice (Security by Obscurity). A related report,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cf6m-vc3m-7cgm

  2. Revision 2 · amended ·

    Amended from osv record GHSA-cf6m-vc3m-7cgm

  3. Revision 1 · created ·

    Published from ghsa record GHSA-cf6m-vc3m-7cgm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-8505

Advisory: Langflow: Unauthenticated Flow Execution via Webhook Authentication Bypass
IDs: CVE-2026-8505, GHSA-cf6m-vc3m-7cgm
Record: https://patchnext.com/advisories/cve-2026-8505 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langflow 1.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow: affected >= 1.7.0, <= 1.9.0; fixed in 1.9.1

## Suggested inspection (read-only)
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cf6m-vc3m-7cgm (GitHub-reviewed advisory GHSA-cf6m-vc3m-7cgm lists affected ranges: PyPI langflow >=1.7.0 <=1.9.0)
- Verified: https://osv.dev/vulnerability/GHSA-cf6m-vc3m-7cgm (OSV record GHSA-cf6m-vc3m-7cgm lists affected ranges: PyPI langflow >=1.7.0 <1.9.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…