undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression
CVE-2026-85024GHSA-3wwx-pv8p-q78v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.10.2, 7.29.1, 6.28.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 6.25.0, < 6.28.1>= 7.28.0, < 7.29.1>= 8.1.0, < 8.10.2
- Fixed in
- 7.29.1, 8.10.2, 6.28.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3wwx-pv8p-q78v lists affected ranges: npm undici >=6.25.0 =7.28.0 =8.1.0 <8.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3wwx-pv8p-q78v lists affected ranges: npm undici >=6.25.0 =7.28.0 =8.1.0 <8.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-85024: 0.41% estimated exploitation activity in the next 30 days; percentile 35.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's WebSocket client (including Node.js's bundled globalThis.WebSocket) crashes the entire Node.js process when a remote WebSocket peer sends a permessage-deflate compressed message that crosses the decompressed-payload size limit and then contains a malformed DEFLATE block. In lib/web/websocket/permessage-deflate.js, the size-limit cleanup calls removeAllListeners() on the internal zlib InflateRaw, removing its error listener, but leaves the stream running. The inflater then emits a ZDATAERROR with no listener attached, which Node.js treats as a fatal unhandled error event and terminates the process. Application error/close handlers on the public WebSocket cannot observe or prevent this, because the failing object is the internal InflateRaw. A malicious or compromised WebSocket server can crash a client with a single connection, unauthenticated and without any application mistake. The attack is asymmetric (about 130 KB on the wire expands past the limit) and can be…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3wwx-pv8p-q78v
- Revision 2 · amended ·
Amended from osv record GHSA-3wwx-pv8p-q78v
- Revision 1 · created ·
Published from ghsa record GHSA-3wwx-pv8p-q78v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-85024 Advisory: undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression IDs: CVE-2026-85024, GHSA-3wwx-pv8p-q78v Record: https://patchnext.com/advisories/cve-2026-85024 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.10.2, 7.29.1, 6.28.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 6.25.0, < 6.28.1; >= 7.28.0, < 7.29.1; >= 8.1.0, < 8.10.2; fixed in 7.29.1, 8.10.2, 6.28.1 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3wwx-pv8p-q78v (GitHub-reviewed advisory GHSA-3wwx-pv8p-q78v lists affected ranges: npm undici >=6.25.0 =7.28.0 =8.1.0 <8.10.2) - Verified: https://osv.dev/vulnerability/GHSA-3wwx-pv8p-q78v (OSV record GHSA-3wwx-pv8p-q78v lists affected ranges: npm undici >=6.25.0 =7.28.0 =8.1.0 <8.10.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…