undici vulnerable to Denial of Service via WebSocketStream unclean close
CVE-2026-85014GHSA-rx4f-c7p8-82vq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.10.2, 7.29.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 7.0.0, < 7.29.1>= 8.0.0, < 8.10.2
- Fixed in
- 7.29.1, 8.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rx4f-c7p8-82vq lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rx4f-c7p8-82vq lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-85014: 0.37% estimated exploitation activity in the next 30 days; percentile 30.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's WebSocketStream crashes the client process when a WebSocket connection is closed abruptly without a close handshake. On such an unclean close, the internal socket-close handler calls abort() on the writable stream even when the application holds a writer lock. Per the WHATWG Streams standard, aborting a locked stream returns a promise that rejects with a TypeError, and the handler discards that promise. The unobserved rejection surfaces as an unhandledRejection and, under Node.js's default behavior, terminates the process. A malicious or compromised WebSocket server can crash a client with a single connection teardown (a TCP reset, a proxy teardown, or a protocol-violating frame). Affected applications are those using the WebSocketStream API and writing through a writer, which is the standard way to write. All releases from undici 7.0.0 are affected. WebSocketStream was introduced in 7.0.0. Patches Upgrade to undici v7.29.1 or v8.10.2. Workarounds No workaround is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rx4f-c7p8-82vq
- Revision 2 · amended ·
Amended from osv record GHSA-rx4f-c7p8-82vq
- Revision 1 · created ·
Published from ghsa record GHSA-rx4f-c7p8-82vq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-85014 Advisory: undici vulnerable to Denial of Service via WebSocketStream unclean close IDs: CVE-2026-85014, GHSA-rx4f-c7p8-82vq Record: https://patchnext.com/advisories/cve-2026-85014 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.10.2, 7.29.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 7.0.0, < 7.29.1; >= 8.0.0, < 8.10.2; fixed in 7.29.1, 8.10.2 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rx4f-c7p8-82vq (GitHub-reviewed advisory GHSA-rx4f-c7p8-82vq lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2) - Verified: https://osv.dev/vulnerability/GHSA-rx4f-c7p8-82vq (OSV record GHSA-rx4f-c7p8-82vq lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…