Skip to content

← Actionable
Low, CVSS 3.7amended

undici vulnerable to caching and replay of unsafe HTTP method responses

CVE-2026-85008GHSA-8436-99hf-9mmv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.10.2, 7.29.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 7.0.0, < 7.29.1>= 8.0.0, < 8.10.2
    Fixed in
    7.29.1, 8.10.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-85008: 0.12% estimated exploitation activity in the next 30 days; percentile 1.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact undici's interceptors.cache() documents that it caches only safe HTTP methods. However, its internal skip-list is built by subtracting the configured methods from the safe-methods set, so an unsafe method (POST, PUT, PATCH, DELETE) never lands in the skip-list and is looked up against the cache store. Combined with the storage gate (canCacheResponse) having no method check, a heuristically-cacheable response (for example a 404) with an explicit Cache-Control: max-age=... to an unsafe method is stored and replayed on a subsequent identical request. The application's state-changing request never reaches the origin, and undici serves a fabricated response from the cache instead. This occurs with the default configuration (methods: ['GET']), which the public API does not allow widening to unsafe methods, so no application misuse is required; an untrusted origin can trigger it purely through its own response headers. Patches Upgrade to 7.29.1 or 8.10.2. The cache interceptor no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8436-99hf-9mmv

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8436-99hf-9mmv

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8436-99hf-9mmv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-85008

Advisory: undici vulnerable to caching and replay of unsafe HTTP method responses
IDs: CVE-2026-85008, GHSA-8436-99hf-9mmv
Record: https://patchnext.com/advisories/cve-2026-85008 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.10.2, 7.29.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 7.0.0, < 7.29.1; >= 8.0.0, < 8.10.2; fixed in 7.29.1, 8.10.2

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8436-99hf-9mmv (GitHub-reviewed advisory GHSA-8436-99hf-9mmv lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2)
- Verified: https://osv.dev/vulnerability/GHSA-8436-99hf-9mmv (OSV record GHSA-8436-99hf-9mmv lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…