md-editor-v3: XSS via fenced-code language rendering bypass
CVE-2026-84992GHSA-3rm2-h79c-8qw6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (md-editor-v3 6.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm md-editor-v3
- Affected
- <= 6.5.3
- Fixed in
- 6.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3rm2-h79c-8qw6 lists affected ranges: npm md-editor-v3 >=0 <=6.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3rm2-h79c-8qw6 lists affected ranges: npm md-editor-v3 >=0 <6.5.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-84992: 0.33% estimated exploitation activity in the next 30 days; percentile 25.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary MdPreview interpolates a fenced-code language into HTML attributes without escaping it. A crafted info string therefore executes JavaScript even when the shipped XSSPlugin is enabled. Details useMarkdownIt() (packages/MdEditor/layouts/Content/composition/useMarkdownIt.ts:206) registers a highlight callback whose final return inserts language into both class="language-${language}" and an unquoted language=${language} attribute without escaping. Both highlighting paths reach this return. XSSPlugin() filters only existing htmlblock and htmlinline tokens before rendering, so it cannot inspect this renderer-generated HTML. PoC The Vue application enables the shipped XSSPlugin and renders attacker-controlled Markdown. noHighlight: true only makes reproduction deterministic; the default highlighting path reaches the same unsafe return. Use this as src/main.js: x"<details/open/ontoggle=alert(document.domain)\nSAFE\n Create and run the app, replacing src/main.js when indicated:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3rm2-h79c-8qw6
- Revision 2 · amended ·
Amended from osv record GHSA-3rm2-h79c-8qw6
- Revision 1 · created ·
Published from ghsa record GHSA-3rm2-h79c-8qw6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84992 Advisory: md-editor-v3: XSS via fenced-code language rendering bypass IDs: CVE-2026-84992, GHSA-3rm2-h79c-8qw6 Record: https://patchnext.com/advisories/cve-2026-84992 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: md-editor-v3 6.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm md-editor-v3: affected <= 6.5.3; fixed in 6.5.4 ## Suggested inspection (read-only) - `npm ls md-editor-v3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on md-editor-v3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3rm2-h79c-8qw6 (GitHub-reviewed advisory GHSA-3rm2-h79c-8qw6 lists affected ranges: npm md-editor-v3 >=0 <=6.5.3) - Verified: https://osv.dev/vulnerability/GHSA-3rm2-h79c-8qw6 (OSV record GHSA-3rm2-h79c-8qw6 lists affected ranges: npm md-editor-v3 >=0 <6.5.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…