undici vulnerable to response truncation via oversized chunked responses in the dump interceptor
CVE-2026-84947GHSA-2gqq-gqf2-x968
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.10.2, 7.29.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 7.1.0, < 7.29.1>= 8.0.0, < 8.10.2
- Fixed in
- 7.29.1, 8.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2gqq-gqf2-x968 lists affected ranges: npm undici >=7.1.0 =8.0.0 <8.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2gqq-gqf2-x968 lists affected ranges: npm undici >=7.1.0 =8.0.0 <8.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-84947: 0.20% estimated exploitation activity in the next 30 days; percentile 9.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's interceptors.dump() reads and discards response bodies up to a configurable maxSize. When a response declares a Content-Length that exceeds maxSize, the request is aborted cleanly. When a response is sent chunked (no Content-Length) and its body exceeds maxSize, it is not aborted: the interceptor ends the response early once the accumulated size reaches maxSize, and continued delivery from the parser triggers an internal assertion that is caught and turned into a request abort and connection tear-down. The application observes a misleading 200 with an empty or truncated body while the connection is disconnected. Any application using the dump interceptor against untrusted or misbehaving upstreams is affected. Patches Upgrade to 7.29.1 or 8.10.2. The dump interceptor now enforces maxSize on both the declared and the received body size, aborting the request with a RequestAbortedError instead of returning a truncated response. Workarounds None. Avoid using…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2gqq-gqf2-x968
- Revision 2 · amended ·
Amended from osv record GHSA-2gqq-gqf2-x968
- Revision 1 · created ·
Published from ghsa record GHSA-2gqq-gqf2-x968
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84947 Advisory: undici vulnerable to response truncation via oversized chunked responses in the dump interceptor IDs: CVE-2026-84947, GHSA-2gqq-gqf2-x968 Record: https://patchnext.com/advisories/cve-2026-84947 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.10.2, 7.29.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 7.1.0, < 7.29.1; >= 8.0.0, < 8.10.2; fixed in 7.29.1, 8.10.2 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2gqq-gqf2-x968 (GitHub-reviewed advisory GHSA-2gqq-gqf2-x968 lists affected ranges: npm undici >=7.1.0 =8.0.0 <8.10.2) - Verified: https://osv.dev/vulnerability/GHSA-2gqq-gqf2-x968 (OSV record GHSA-2gqq-gqf2-x968 lists affected ranges: npm undici >=7.1.0 =8.0.0 <8.10.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…