undici vulnerable to cross-user cookie disclosure via Set-Cookie caching in shared caches
CVE-2026-84933GHSA-2jfj-6hjv-fm6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.10.2, 7.29.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 7.0.0, < 7.29.1>= 8.0.0, < 8.10.2
- Fixed in
- 7.29.1, 8.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2jfj-6hjv-fm6j lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2jfj-6hjv-fm6j lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-84933: 0.30% estimated exploitation activity in the next 30 days; percentile 23.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's interceptors.cache() does not handle Set-Cookie in the cache path. In shared-cache mode (type: 'shared', the default), a cacheable response (for example Cache-Control: public, max-age=...) carrying a Set-Cookie header is stored, and the stored Set-Cookie is re-served to a later caller that hits the same cache key. This exposes one user's cookie to another caller and lets an untrusted upstream inject cookies into cached responses served to all subsequent callers, violating RFC 6265 section 7.2 (a shared cache must not store cookies). Applications using the shared cache interceptor against untrusted or multi-user upstreams are affected. Private caches (type: 'private') are not affected. Patches Upgrade to 7.29.1 or 8.10.2. In shared-cache mode, undici no longer stores or re-serves responses containing Set-Cookie, including previously cached entries and revalidation paths. Workarounds Use a private cache (type: 'private') for per-user responses, or avoid caching…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2jfj-6hjv-fm6j
- Revision 2 · amended ·
Amended from osv record GHSA-2jfj-6hjv-fm6j
- Revision 1 · created ·
Published from ghsa record GHSA-2jfj-6hjv-fm6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84933 Advisory: undici vulnerable to cross-user cookie disclosure via Set-Cookie caching in shared caches IDs: CVE-2026-84933, GHSA-2jfj-6hjv-fm6j Record: https://patchnext.com/advisories/cve-2026-84933 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.10.2, 7.29.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 7.0.0, < 7.29.1; >= 8.0.0, < 8.10.2; fixed in 7.29.1, 8.10.2 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2jfj-6hjv-fm6j (GitHub-reviewed advisory GHSA-2jfj-6hjv-fm6j lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2) - Verified: https://osv.dev/vulnerability/GHSA-2jfj-6hjv-fm6j (OSV record GHSA-2jfj-6hjv-fm6j lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.10.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…