Skip to content

← Actionable
High, CVSS 8.1amended

fastify vulnerable to request body replacement via an async validation result collision

CVE-2026-84504GHSA-667r-xxjv-c9mm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 5.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fastify

    Affected
    < 5.12.2
    Fixed in
    5.12.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-84504: 0.43% estimated exploitation activity in the next 30 days; percentile 37.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Fastify runs a route's validator and, for a result shaped like { value, error }, unwraps it: an error becomes a validation failure and value replaces the request part. This convention is intended for synchronous custom compilers (for example Joi). A JSON Schema $async validator, however, resolves with the validated data itself, so Fastify applied the same unwrapping to it. If a request part validated by an $async schema contains a value property, Fastify replaced the whole request part with that nested value before the handler ran, so a value or error property in the payload was attacker-controlled. An application that dispatches operations from the validated request body could then act on data that never satisfied the route schema, leading to unauthorized state changes or disclosure. Reaching the vulnerable path requires the route to use an $async request schema. Patches Fastify no longer treats an asynchronous validation result as a { value, error } wrapper: an async…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-667r-xxjv-c9mm

  2. Revision 2 · amended ·

    Amended from osv record GHSA-667r-xxjv-c9mm

  3. Revision 1 · created ·

    Published from ghsa record GHSA-667r-xxjv-c9mm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84504

Advisory: fastify vulnerable to request body replacement via an async validation result collision
IDs: CVE-2026-84504, GHSA-667r-xxjv-c9mm
Record: https://patchnext.com/advisories/cve-2026-84504 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastify 5.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fastify: affected < 5.12.2; fixed in 5.12.2

## Suggested inspection (read-only)
- `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-667r-xxjv-c9mm (GitHub-reviewed advisory GHSA-667r-xxjv-c9mm lists affected ranges: npm fastify >=0 <5.12.2)
- Verified: https://osv.dev/vulnerability/GHSA-667r-xxjv-c9mm (OSV record GHSA-667r-xxjv-c9mm lists affected ranges: npm fastify >=0 <5.12.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…