Skip to content

← Actionable
High, CVSS 7.5amended

fastify vulnerable to request validation bypass via skipped boolean false schemas

CVE-2026-84469GHSA-hwr6-493r-vm6h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 5.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fastify

    Affected
    < 5.12.2
    Fixed in
    5.12.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-84469: 0.49% estimated exploitation activity in the next 30 days; percentile 42.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Fastify decided whether to validate a request part by checking its schema for JavaScript truthiness. JSON Schema Draft 7 defines the boolean false as a valid schema that rejects every instance, but because false is falsy, a route that set body, querystring, params, or headers to false had that part left uncompiled: no validator was attached and the request reached the handler. An application that used false as a deny-all schema to make a route unreachable was therefore fully bypassed, and an unauthenticated remote client could reach the handler with any input. The same applied to the documented query alias for querystring. This is a complete bypass rather than a weak-schema issue, since false is the strongest JSON Schema assertion and must always fail. Patches Request-part schemas are now selected by an explicit presence check rather than truthiness, so a boolean false (or true) schema is compiled and enforced, including through the query alias. Patched in fastify 5.12.2. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hwr6-493r-vm6h

  2. Revision 2 · amended ·

    Amended from osv record GHSA-hwr6-493r-vm6h

  3. Revision 1 · created ·

    Published from ghsa record GHSA-hwr6-493r-vm6h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84469

Advisory: fastify vulnerable to request validation bypass via skipped boolean false schemas
IDs: CVE-2026-84469, GHSA-hwr6-493r-vm6h
Record: https://patchnext.com/advisories/cve-2026-84469 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastify 5.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fastify: affected < 5.12.2; fixed in 5.12.2

## Suggested inspection (read-only)
- `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hwr6-493r-vm6h (GitHub-reviewed advisory GHSA-hwr6-493r-vm6h lists affected ranges: npm fastify >=0 <5.12.2)
- Verified: https://osv.dev/vulnerability/GHSA-hwr6-493r-vm6h (OSV record GHSA-hwr6-493r-vm6h lists affected ranges: npm fastify >=0 <5.12.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…