Skip to content

← Actionable
High, CVSS 7.5amended

HTTPX2: Streaming response decompression does not bound peak memory (decompression amplification)

CVE-2026-84382GHSA-8xx6-hgc6-gc2m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (httpx2 2.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI httpx2

    Affected
    < 2.12.0
    Fixed in
    2.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-84382: 0.63% estimated exploitation activity in the next 30 days; percentile 50.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When decoding a compressed response body (gzip, deflate, br, or zstd), HTTPX2 fully decompressed each network read before yielding content to the application. A small compressed input could therefore cause a large intermediate memory allocation, even when the application streamed the response to keep memory usage bounded. Details HTTPX2's default transport reads the socket in pieces of up to 64 KiB. Before 2.12.0, each piece was inflated completely into one intermediate allocation before any decompressed bytes were yielded. At DEFLATE's maximum compression ratio of roughly 1032:1, a 64 KiB compressed chunk can expand to about 64 MiB in one allocation. Brotli and Zstandard responses can cause similarly large amplification. Streaming the response did not prevent these transient allocations. Impact Applications that fetch resources from untrusted or attacker-influenced servers - such as webhook receivers, link unfurlers, crawlers, SSRF-reachable fetchers, and redirect followers…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8xx6-hgc6-gc2m

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8xx6-hgc6-gc2m

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8xx6-hgc6-gc2m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84382

Advisory: HTTPX2: Streaming response decompression does not bound peak memory (decompression amplification)
IDs: CVE-2026-84382, GHSA-8xx6-hgc6-gc2m
Record: https://patchnext.com/advisories/cve-2026-84382 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: httpx2 2.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI httpx2: affected < 2.12.0; fixed in 2.12.0

## Suggested inspection (read-only)
- `python -m pip show httpx2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on httpx2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8xx6-hgc6-gc2m (GitHub-reviewed advisory GHSA-8xx6-hgc6-gc2m lists affected ranges: PyPI httpx2 >=0 <2.12.0)
- Verified: https://osv.dev/vulnerability/GHSA-8xx6-hgc6-gc2m (OSV record GHSA-8xx6-hgc6-gc2m lists affected ranges: PyPI httpx2 >=0 <2.12.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…