HTTPX2: Secure WebSocket traffic sent without TLS through SOCKS proxies
CVE-2026-84381GHSA-7mj9-2mp8-4m2p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (httpcore2 2.10.0; httpx2 2.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mj9-2mp8-4m2p lists affected ranges: PyPI httpcore2 >=0 =2.6.0 <2.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7mj9-2mp8-4m2p lists affected ranges: PyPI httpcore2 >=0 =2.6.0 <2.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-84381: 0.08% estimated exploitation activity in the next 30 days; percentile 0.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary httpcore2 does not start TLS for wss:// connections routed through a SOCKS5 proxy. The WebSocket opening handshake and all subsequent frames are sent in plaintext through the proxy path, despite the caller selecting the secure wss scheme. The transport flaw affects httpcore2 releases before 2.10.0. HTTPX2 exposed this behavior through its public Client.websocket() and AsyncClient.websocket() APIs from 2.6.0 through 2.9.1. Details The synchronous and asynchronous SOCKS5 connection implementations upgrade the established proxy tunnel to TLS only when the remote origin scheme is https. The equivalent check does not include wss. After the SOCKS5 handshake succeeds, the raw stream is therefore passed directly to the HTTP/1.1 connection, which writes the WebSocket upgrade request without first performing a TLS handshake or verifying the destination certificate. For example, an application using HTTPX2 2.6.0 through 2.9.1 may open an authenticated WebSocket through a SOCKS proxy: On…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7mj9-2mp8-4m2p
- Revision 2 · amended ·
Amended from osv record GHSA-7mj9-2mp8-4m2p
- Revision 1 · created ·
Published from ghsa record GHSA-7mj9-2mp8-4m2p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84381 Advisory: HTTPX2: Secure WebSocket traffic sent without TLS through SOCKS proxies IDs: CVE-2026-84381, GHSA-7mj9-2mp8-4m2p Record: https://patchnext.com/advisories/cve-2026-84381 (revision 3, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: httpcore2 2.10.0; httpx2 2.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI httpcore2: affected < 2.10.0; fixed in 2.10.0 - PyPI httpx2: affected >= 2.6.0, < 2.10.0; fixed in 2.10.0 ## Suggested inspection (read-only) - `python -m pip show httpcore2`: prints the installed version. Run with the environment that serves production active. - `python -m pip show httpx2`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on httpcore2, httpx2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7mj9-2mp8-4m2p (GitHub-reviewed advisory GHSA-7mj9-2mp8-4m2p lists affected ranges: PyPI httpcore2 >=0 =2.6.0 <2.10.0) - Verified: https://osv.dev/vulnerability/GHSA-7mj9-2mp8-4m2p (OSV record GHSA-7mj9-2mp8-4m2p lists affected ranges: PyPI httpcore2 >=0 =2.6.0 <2.10.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…