Skip to content

← Actionable
Medium, CVSS 5.9amended

HTTPX2: Quadratic SSE line buffering can cause CPU denial of service

CVE-2026-84378GHSA-f2fp-rgf2-35cp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (httpx2 2.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI httpx2

    Affected
    >= 2.5.0, < 2.10.0
    Fixed in
    2.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-84378: 0.32% estimated exploitation activity in the next 30 days; percentile 24.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary HTTPX2's Server-Sent Events (SSE) parser repeatedly copied and rescanned buffered text when a server split one unterminated line across many response chunks. The total work grows quadratically with the length of the line. An attacker-controlled or compromised SSE endpoint can exploit this behavior to consume excessive client CPU. Details Before version 2.10.0, HTTPX2 combined the complete pending SSE line with each newly received chunk and then scanned the combined text for line separators. If an SSE server sends a long line as many small chunks without a line separator, every chunk causes all previously received text to be copied and scanned again. For n fixed-size chunks, this results in O(n²) processing. The behavior affects both httpx2.Client.sse() and httpx2.AsyncClient.sse(). Other response APIs do not use the SSE parsing path. Impact Applications that consume SSE from an attacker-controlled or compromised endpoint can experience excessive CPU usage. A crafted stream…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f2fp-rgf2-35cp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-f2fp-rgf2-35cp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-f2fp-rgf2-35cp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84378

Advisory: HTTPX2: Quadratic SSE line buffering can cause CPU denial of service
IDs: CVE-2026-84378, GHSA-f2fp-rgf2-35cp
Record: https://patchnext.com/advisories/cve-2026-84378 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: httpx2 2.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI httpx2: affected >= 2.5.0, < 2.10.0; fixed in 2.10.0

## Suggested inspection (read-only)
- `python -m pip show httpx2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on httpx2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f2fp-rgf2-35cp (GitHub-reviewed advisory GHSA-f2fp-rgf2-35cp lists affected ranges: PyPI httpx2 >=2.5.0 <2.10.0)
- Verified: https://osv.dev/vulnerability/GHSA-f2fp-rgf2-35cp (OSV record GHSA-f2fp-rgf2-35cp lists affected ranges: PyPI httpx2 >=2.5.0 <2.10.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…