Skip to content

← Actionable
Critical, CVSS 9.8amended

Predis: Redis command injection and denial of service via CRLF smuggling in pipelined commands on aggregate connections

CVE-2026-84372GHSA-w6f5-v2h6-g786

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (predis/predis 3.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist predis/predis

    Affected
    >= 3.0.0-RC1, < 3.3.0
    Fixed in
    3.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-84372: 0.73% estimated exploitation activity in the next 30 days; percentile 54.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An improper CRLF neutralization flaw in Predis' pipeline handling on aggregate connections lets an unauthenticated attacker who can influence any pipelined argument — a value or a key, e.g. a URL slug used as a cache key — smuggle arbitrary Redis commands into the connection. - On cluster connections (cluster option, incl. client-side sharding) this is remote command injection: shard-wide FLUSHDB, targeted DEL/SET, same-slot key theft via GET, cache poisoning, and possible node/cluster outage. - On replication connections (replication option) it is a reliable, repeatable denial of service (uncaught fatal error) triggered by any value containing \r\n. Details When a pipeline is executed over an aggregate connection, AbstractAggregateConnection::write() re-parses the already-serialized pipeline buffer with explode("\r\n") instead of honoring RESP length prefixes: - https://github.com/predis/predis/blob/v3.2.0/src/Connection/AbstractAggregateConnection.php#L78-L94 - splits the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w6f5-v2h6-g786

  2. Revision 1 · created ·

    Published from osv record GHSA-w6f5-v2h6-g786

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84372

Advisory: Predis: Redis command injection and denial of service via CRLF smuggling in pipelined commands on aggregate connections
IDs: CVE-2026-84372, GHSA-w6f5-v2h6-g786
Record: https://patchnext.com/advisories/cve-2026-84372 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: predis/predis 3.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist predis/predis: affected >= 3.0.0-RC1, < 3.3.0; fixed in 3.3.0

## Suggested inspection (read-only)
- Packagist predis/predis: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on predis/predis.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w6f5-v2h6-g786 (OSV record GHSA-w6f5-v2h6-g786 lists affected ranges: Packagist predis/predis >=3.0.0-RC1 <3.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w6f5-v2h6-g786 (GitHub-reviewed advisory GHSA-w6f5-v2h6-g786 lists affected ranges: Packagist predis/predis >=3.0.0-RC1 <3.3.0)

Commands are suggestions: review each one before running it.

Loading voting…